"Database connection errors" when starting Advance Steel

Autodesk Support

Sep 30, 2024


Products and versions covered


Issue:

Users reported that when starting Advance Steel, the following message is displayed:

Database connection errors

Failed to connect to the following databases:

C:\ProgramData\Autodesk\Advance Steel 20xx\INT\Steel\Data\AstorRules.mdf
C:\ProgramData\Autodesk\Advance Steel 20xx\INT\Steel\Data\AstorDetails.mdf
C:\ProgramData\Autodesk\Advance Steel 20xx\INT\Steel\Data\AstorBase.mdf

(A different language code might be shown instead of INT, like USA, DEU ...)


Database Connection error: Failed to connect to databases in Advance Steel

 
 

Causes:

  • The message "Failed to connect to the following databases: ... " is generic, indicating only that Advance Steel cannot connect to one or several of its databases.
  • Advance Steel needs to connect to the SQL Server instance managing its databases, and then to open the databases.

Here is a list with different scenarios when the message can be shown:

  1. The connection to the database itself cannot be done

  • The MDF database and its associated LDF files are incompatible;
  • The database file is missing from the expected folder;
  • The folder containing the database(s) is not fully accessible (Read & Write) by the user;
  • The database file is marked as Read-Only;
  • The version of the SQL database is higher than the installed SQL version.
  • The database is corrupt/invalid.
  1. The connection to the SQL Server / instance cannot be completed

  • The SQL Server LocalDB is not installed.
  • The SQL Server LocalDB installation or SQL instance is corrupted.
  • System with sector size greater than 4k.
  • Third-party application prevents connection to SQL Server (for example, Ad-Aware Web Companion (Lavasoft), Document Locator).
  • The SQL Server is not accessible through network.
  • Cannot see the network SQL server instance (ports, firewall settings).
  • There are not enough rights to connect to the SQL instance.
  1. Error within the "DatabaseConfiguration.XML" file

  • The database path is incorrect or incomplete.
  • The server name or instance name is incorrect.
  • The communication port to the server machine / instance is incorrect.
  • Typos.
  1. Incomplete Installation/Installation error 

  2. Copying databases from a machine with higher versions of SQL installed such as SQL2019.

  • Advance Steel 2024 and 2025 uses SQL 2019 databases.
  • Lower versions of Advance Steel cannot be launched using these databases
     

Solution:

To solve the issue, identify the scenario that causes the "database connection error" message and apply the specific solution.

  •  If the message appears after installation on Windows 11, follow the steps from this article to check & fix the sector size:

  • If the message appears right after install, see the reported folder path for database in the message. If it is in the form of: C:\ProgramData\Autodesk\Advance Steel Objects\20xx\Data\
    Then use this dedicated article to investigate the installation:

  • If this message appears while trying to place the Advance Steel databases on a shared location, start by following the steps indicated in this dedicated article:

  • To narrow down one or more possible causes of the message, use the following workflow to verify the connection to SQL database: How to verify access to an Advance Steel SQL database

  •  When the database is corrupt or invalid

  • Get the official version of the database.

  • For example, copy the corresponding database from a different installation / different computer. 

  • When the application "Ad-Aware Web Companion" (Lavasoft) is installed on the machine, follow these steps:

  1. Open the Task Manager by right-clicking the taskbar or pressing CTRL+SHIFT+ESC.

  2. Find the process/service LavasoftTcpService and right-click -> End task.

  3. Open Programs and Features with the Windows Control Panel.

  4. Find the Web Companion application and uninstall it.

  5. Navigate to the folder C:\Windows\System32 and C:\Windows\SysWOW64 and rename or delete these files:

    • LavasoftTcpService.dll

    • LavasoftTcpService64.dll

  • If this message appears after copying the database(s) from another location (folder or machine), make sure that the LDF files have been deleted:

  1. Go to the destination folder (where the database has been copied to).

  2. Search for the LDF file corresponding to the copied database and delete it. For example, if the AstorProfiles.MDF database is copied from another location:

  3. Go to the destination folder [C:]\ProgramData\Autodesk\Advance Steel [version]\[language]\Steel\Data\

  4. Delete the file AstorProfiles_log.LDF


If the database message persists when starting Advance Steel product, contact Support and open a Technical support request for further investigations.

Products:

Advance Steel;


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