Vários processos do Autodesk AdskLicensingAgent.exe em execução no Gerenciador de Tarefas

Autodesk Support

8 de outubro de 2023


Produtos e versões cobertos


Problema:

Ao executar o software da Autodesk, várias instâncias do processo Autodesk AdskLicensingAgent.exe aparecem no Gerenciador de Tarefas, com alto uso dos recursos do computador.

Causas:

  • Serviço de licenciamento de desktop da Autodesk desatualizado ou corrompido.
  • Em um ambiente de licença de rede, isso pode ser causado por uma incompatibilidade entre as variáveis ADSKFLEX_LICENSE_FILE e o valor em cache do AdskLicensing para o servidor de licença. 

Solução:

Para resolver o problema, tente as seguintes soluções:
 

Atualizar o Serviço de Licenciamento de Desktop da Autodesk

Consulte Download do Serviço de Licenciamento da Autodesk.


Inspecionar os valores do servidor de licenças armazenados no registro e no AdskLicensing (somente licença de rede)

  1. Abra um prompt de comando elevado (pressione WIN+R > digite cmd > pressione CTRL+SHIFT+ENTER).
  2. Digite e execute o comando "C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Current\helper\AdskLicensingInstHelper.exe" list
  3. Inspecione o valor de "lic_servers" do produto afetado (abaixo do Maya 2022, por exemplo):
image.png
  1. Abra o Registro do Windows (pressione WIN+R > digite regedit > pressione CTRL+SHIFT+ENTER).
  2. Inspecione a chave HKEY_CURRENT_USER\SOFTWARE\FLEXlm License Manager\ADSKFLEX_LICENSE_FILE e assegure-se de que o valor corresponda a:
image.png
  • Se o valor não coincidir (como abaixo). Clique duas vezes na chave e modifique-a.image.png

Alternativamente, remova a variável ADSKFLEX_LICENSE_FILE. Na próxima inicialização do produto, ele será recriado automaticamente com base no valor armazenado no Serviço de licenciamento da Autodesk.

Aviso
Problemas causados ao editar incorretamente o Registro do Windows poderiam inutilizar o sistema operacional do seu computador. A Microsoft fornece várias informações críticas que você deve conhecer sobre o Registro na Base de Conhecimento da Microsoft. Use o Editor do Registro da Microsoft por sua conta e risco, e somente depois de fazer backup do Registro conforme descrito para o seu sistema operacional no artigo da Microsoft sobre como fazer o backup e a restauração no Windows e na solução relacionada Como fazer backup do Registro do sistema. Mais informações sobre o Registro estão contidas nos tópicos de Ajuda do Editor de Registro da Microsoft.

 

Limpe o sistema para verificar se há algum problema com o Serviço de Licenciamento de Desktop da Autodesk

Consulte Como executar uma desinstalação limpa de produtos da Autodesk no Windows.

Produtos:

Todos os produtos para desktop;

Versões:

2020; 2021; 2022; 2023;


Essas informações foram úteis?


Precisa de ajuda? Pergunte ao Autodesk Assistant!

O assistente pode ajudar você a encontrar respostas ou falar com um agente.


Qual é o seu nível de suporte?

Diferentes planos de assinatura oferecem categorias distintas de suporte. Saiba qual é o nível de suporte do seu plano.

Visualizar níveis de suporte