O Dynamo trava com CER ao criar um novo nó ou abrir um script do Civil 3D

Autodesk Support

8 de outubro de 2023


Produtos e versões cobertos


Problema:

Criar um novo nó ou abrir um script no Dynamo para Civil 3D causa erro fatal no aplicativo com CER (Relatório de erro do cliente). A seguinte mensagem de erro pode aparecer:

AutoCAD

Ocorreu uma exceção sem tratamento em um componente do seu aplicativo.
Se você clicar em Continuar, o aplicativo ignorará esse erro e tentará continuar.

Adicionar valor à coleção do tipo 'System.Windows.Interativity.TriggerActionCollection' gerou uma exceção.

image.png

Causas:

Complemento conflitante.

Solução:

Desative os complementos do Civil 3D e, em seguida, verifique se o Dynamo funciona como esperado:
  1. Feche o Civil 3D.
  2. Localize as seguintes pastas:
C:\Program Files\Autodesk\ApplicationPlugins\
C:\Program Files (x86)\Autodesk\ApplicationPlugins\
C:\ProgramData\Autodesk\ApplicationPlugins\
C:\Users\username\AppData\Roaming\Autodesk\ApplicationPlugins
  1. Mova temporariamente os arquivos do complemento das pastas acima para outra localização.
  2. Inicie o Civil 3D. Os complementos serão desabilitados.
Observação: Se o Dynamo funcionar como esperado após a etapa anterior, mova os complementos um a um de volta para as pastas originais até encontrar o complemento conflitante. 

Produtos:

Civil 3D; Dynamo;

Versões:

2022; 2023;


Essas informações foram úteis?


Precisa de ajuda? Pergunte ao Autodesk Assistant!

O assistente pode ajudar você a encontrar respostas ou falar com um agente.


Qual é o seu nível de suporte?

Diferentes planos de assinatura oferecem categorias distintas de suporte. Saiba qual é o nível de suporte do seu plano.

Visualizar níveis de suporte