Mensagem "System.ArgumentNullException" ao iniciar o Dynamo a partir do Revit

Autodesk Support

8 de outubro de 2023


Produtos e versões cobertos


Problema:

O Dynamo não pode ser iniciado a partir do Revit, a seguinte mensagem será exibida:

"System.ArgumentNullException [...]"

SystemNullException.png

Causas:

Uma versão desatualizada do ADPClientService está instalada no computador.

Solução:

Siga as etapas para verificar e atualizar a versão do ADPClientService:

1. Ir para a pasta - C:\Program Files\Autodesk\AdODIS\V1\Setup - and locate ADPClientService.exe
2. Clique com o botão direito do mouse em ADPClientService.exe.
3. Selecione Propriedades -> guia Detalhes e verifique a Versão do arquivo. Verifique se a versão de ADPClientService.exe é 4.1.38 ou superior. 
Step1.png
4. Faça o download dos binários mais recentes dos anexos para instalá-los.
5. Clique duas vezes para iniciar o ADPClientService.exe. Uma janela do console será exibida por alguns segundos e será fechada. Se ele não fechar, digamos após 10-15 segundos, feche-o manualmente.

Observações:

  • Ao seguir as etapas acima, o ADPClientService.exe será copiado para a pasta do usuário (%appdata%\Autodesk\ADPSDK\bin) junto com suas dependências. Depois disso, qualquer produto que use este serviço usará os binários mais recentes do ADPClientService deste local. 
  • Podem ser necessários privilégios de administrador para instalar os binários mais recentes do AdODIS.

Produtos:

Família de produtos Revit; Dynamo;

Versões:

2021;


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