Solução de problemas de conexões com falha com o servidor do Vault com o uso de VPN

Autodesk Support

6 de dezembro de 2024


Produtos e versões cobertos


Problema:

Estou buscando ajuda para resolver problemas de conectividade do cliente do Autodesk Vault com o servidor do Vault por meio de uma VPN (Virtual Private Network, Rede privada virtual). O que verificar quando é impossível acessar o servidor do Vault usando somente a conexão VPN? Como resolver o problema ao tentar acessar o Vault Server por meio de VPN usando a autenticação do Windows?

Causas:

Para uma conta do Vault, ao fazer login em um servidor do Vault, parecerá que o software só precisa se conectar a um servidor. No entanto, alguns recursos do Vault exigem que o cliente se conecte a outros servidores. Por exemplo: 

  • AVFS (Autodesk Vault File Server),
  • Licenciamento,
  • Autenticação do Windows.

Essa comunicação fica oculta para um usuário.

Servidor do Vault

Todos os clientes do Vault devem se conectar ao computador ADMS (Autodesk Data Management Server).

AVFS (Autodesk Vault File Server)

Se estiver se conectando a um AVFS, o software cliente do Vault deve ser capaz de se conectar às máquinas do ADMS e do AVFS. (O AVFS é um recurso somente do Vault Professional)

Licenciamento

O licenciamento na modalidade Usuário único requer que os clientes do Vault se conectem aos servidores da Autodesk para validar se a conta ID Autodesk do usuário tem direito de usar o software uma vez por mês. (isso inclui clientes Vault Basic)

O licenciamento Multiusuário requer que o cliente do Vault se conecte ao servidor de licenciamento de rede sempre que o software do servidor do Vault for executado e se reconecte a cada 30 minutos para verificar se o uso do software está ativo.
 

Autenticação do Windows (somente compatível com o Vault Professional)

O Vault oferece suporte a várias tecnologias de autenticação. Se for usada uma "Conta do Windows", o cliente do Vault precisará se autenticar em um servidor Ative Directory.

Login no Vault com o uso da autenticação do Windows

 

Se a conectividade de rede básica não estiver funcionando para nenhum dos servidores, não será possível efetuar login no servidor do Vault. Como verificar a conectividade de rede básica entre um cliente do Vault e o servidor do Vault?

Se um firewall estiver bloqueando as portas necessárias à conexão com o servidor para os protocolos em uso (HTTP ou HTTPS, FlexLM, LDAP), não será possível efetuar login no servidor do Vault.

Se não for possível resolver o problema com a VPN, considere a possibilidade de usar o Gateway do Vault para se conectar ao servidor do Vault.

Solução:

Verificações básicas

As conexões com o Servidor do Vault se enquadram em duas categorias; 

  • Dentro do firewall
Conexões com o servidor do Vault no firewall
 

 

  • Fora do firewall
Conexões com o servidor do Vault fora do firewall
 


Em primeiro lugar, tente conectar o cliente do Vault ao servidor do Vault enquanto eles estão conectados à mesma LAN (rede local), quando os dois computadores estiverem dentro do firewall.

Em seguida, após retirar esse cliente do firewall, tente conectá-lo ao servidor do Vault.

Se a única alteração tiver sido a saída do computador cliente do Vault do firewall, isso significa que:

  • O Roteador de VPN e\ou firewall não foi configurado para permitir a passagem do tráfego do Vault, do licenciamento ou da Autenticação do Windows.
  • Existem problemas com as configurações de DNS no roteador de VPN. 

Observação: Para resolver esses problemas, entre em contato com o roteador de VPN\TI interna\administrador de rede. A Autodesk não pode resolver nem solucionar problemas com sua rede. A operação está fora do controle da Autodesk. Os seguintes artigos ajudarão:

Ferramentas úteis de solução de problemas (para execução no cliente do Vault)

  • Tracert. Essa ferramenta de linha de comando pode identificar o percurso do tráfego de rede entre o cliente e o servidor. 
  • TCPView. Trata-se de uma ferramenta de interface do usuário que pode ajudar a identificar quais portas um processo está utilizando e quais podem então ser abertas no firewall\roteador.
  • Fiddler. Essa ferramenta pode ser usada para rastrear o tráfego HTTP/HTTPS e quaisquer possíveis erros. Se alguma mensagem de erro 4xx ou 5xx for reportada no Fiddler, verifique nos arquivos de registro W3SVC no servidor do Vault se as chamadas estão passando pelo servidor. Se as chamadas não forem completadas, isso será considerado uma evidência irrefutável de que fatores fora do controle do software Autodesk estão bloqueando as chamadas. 

Uma palavra sobre servidores proxy

Se as opções da Internet estiverem configuradas para usar um servidor proxy, uma ferramenta de rastreamento HTTP\HTTPS (como o Wireshark ou o Fiddler) poderá mostrar as conexões do cliente do Vault que está sendo enviado ao servidor proxy. Isso deverá ser levado em conta na configuração da rede.
Se os clientes dentro do firewall também estiverem com problemas para se conectar ao servidor do Vault, este artigo ajudará a diagnosticar o problema.
 

Produtos:

Produtos Vault;


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