"Failed to open document" error when linking cloud model via Desktop Connector to a Revit model

Autodesk Support

Jan 7, 2025


Products and versions covered


Issue:

When linking or reloading a cloud model using the Desktop Connector to a Revit model, the following error is seen:

Revit

Failed to open document.
Failed to open document

 
 

Causes:

Damaged Desktop Connector Local cache file.

The Revit journal will record lines similar to the following when trying to load the link:
' [Jrn.ModelOperation] Rvt.Attr.Scenario: ModelOpen COMMON.OS_VERSION:  Rvt.Attr.ModelVerEpisode: 00000000-0000-0000-0000-000000000000 -1 , Rvt.Attr.ModelPath: RVT[####################] Rvt.Attr.ModelSize: 0 Rvt.Attr.DetectDuration: -1 Rvt.Attr.Worksharing: UnknownWorksharingState Rvt.Attr.ModelState: InvalidOleStructure Rvt.Attr.DiskType: 
'C DD-Mmm-YYYY HH:MM:SS.SSS;   4:< Load exception "COleException", code=0x80030109: The docfile has been corrupted.
'C DD-Mmm-YYYY HH:MM:SS.SSS;   4:< COleServerDoc::ReportSaveLoadException
' 4:< TaskDialog "Failed to open document."
'CommonButtons : Close
 

Solution:

If the link is a cloud model, link through External Resources

Link cloud models through External Resources: Difference between External Resource and Desktop Connector, when linking cloud models in Revit.
Note: If the external Resources window is blank see the following article: Missing hubs, folders and models in the External Resources area when adding an RVT link to cloud model in Revit.

File Downloading

Wait for the model to download from Desktop Connector and then try linking again.

Clear Cache

Reinstall Desktop Connector

If removing the cached files does not clear the error, go through the following steps to uninstall/reinstall the Desktop Connector: 

  1. Uninstall the application through the Control Panel.
  2. Delete the following folders: 
  • C:\Users\%USERNAME%\AppData\Local\Autodesk\Desktop Connector
  • C:\Users\%USERNAME%\AppData\Local\Autodesk\Web Services\DesktopConnector
  1. Delete the following registry keys (be advised that it is recommend to first export out or 'save' a copy of the current registry before deleting or modifying any keys):
  • HKEY_CURRENT_USER\SOFTWARE\Autodesk\Autodesk Desktop Connector
  • HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Desktop Connector
  1. Restart the computer.
  2. Reinstall the application.

More Troubleshooting

If journal entries like the ones listed above are not showing up on your system, check if ones of the following articles apply:
Journal EntriesArticle
Collaborate.dll is not signed and cannot be an internal addin"Failed to open document" when opening a cloud workshared model in Revit
Load exception "COleException", code=0x80004005: Unspecified error"Failed to open document" when working with Revit cloud model containing Desktop Connector links

If the articles above don't apply, check this link for more articles on this error: "Failed to open document"

Products:

Revit Product Family; Revit Cloud Worksharing; BIM 360; Construction Cloud; Desktop Connector;


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