"Install failed - Error 1603. Fatal error during installation." when installing Autodesk products 2020 or above versions

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

Users reported that the following window pops up when installing Autodesk products 2020 or above versions.
 

Install failed - Error 1603

Fatal error during installation
 
autocad lt 2022 install failed error 1603 fatal error during installation
 
 
 

Causes:

  • Autodesk Desktop Licensing Service is not running or not running properly due to permissions.
  • Windows Installer issue. 
  • Visual C++ redistributable is corrupt.
  • Microsoft .Net framework failed to install or was corrupted.
  • Corrupted installation of the program.
  • Corrupted installation of a product update. 
  • Corrupted residual component installed. 
  • Autodesk Desktop Licensing Service is set to run as "This account" in Windows Services.
  • Conflict with security software. 

Solution:

Follow one or more of the following solutions to solve the issue:

Update the Autodesk Desktop Licensing Service and the Autodesk Identity Component.

  1. Download and install the latest update for:
  2. Try again to start your product.


Uninstall and Reinstall the Autodesk Desktop Licensing Service

  1. Uninstall Autodesk Desktop Licensing Service.
  2. Download and install the latest Autodesk Desktop Licensing Service.


Restart or check if the Autodesk Desktop Licensing Service is running

See How to check the status of Autodesk Desktop Licensing Service


Uninstall and reinstall Autodesk Installer

  1. Go to C:\Program Files\Autodesk\AdODIS\V1.
  2. Right-click RemoveODIS.exe and select "Run as Administrator".
  3. Download the latest version of Autodesk Installer.
  4. Run AdODIS-installer.exe.

Uninstall and reinstall Microsoft Visual C++ Redistributable

See How to remove and reinstall Microsoft Visual C++ Redistributables packages


Security software conflict

Configuring the settings of, disabling, or uninstalling security software may be required. Refer to: Autodesk Licensing Service: Known Conflicting Applications.


Remove previous corrupted installation

  • Remove with Microsoft Troubleshooter (also known as Fix-It) old residual leftover installation for the software that you are trying to install. 
  • Check the Registry for any potential leftover installation for the software you are trying to install and remove it manually (Note. Be careful with the Windows Registry. If you are not an expert, ask your Admin to perform this step!).


Clean uninstall and reinstall

  1. Perform a Clean Uninstall, see How to perform a Clean Uninstall of Autodesk products on Windows.
  2. Reinstall the product.

Products:

All Desktop Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support