“The feature you are trying to use is on a network resource that is unavailable” when installing/uninstall an Autodesk product

Autodesk Support

Feb 21, 2025


Products and versions covered


Issue:

When installing/uninstalling an Autodesk product that uses the new installation framework (Does my product or update use the Autodesk New Installation Experience or the Classic Installer?) an error message similar to the following appears:

installer error message The feature you are trying to use is on a network resource that is unavailable.   Click OK to try again, or enter an alternate path Use source: C:\ProgramData\Package Cach e\…


Note. This can happen with several different *.msi files such as the following examples:

 

For all Products:

  • dotnet-host-8.0.0-win-x64.msi
  • dotnet-host-8.0.6-win-x64.msi
  • vc_runtimeMinimum_x64.msi.
  • vc_runtimeMinimum_x86.msi.
  • vc_runtimeAdditional_x64.msi.
  • vc_runtimeAdditional_x86.msi.
  • AdSSO.msi.
  • Autodesk Genuine Service.msi.
  • AutodeskGuidedTutorialPlugin.msi.
  • autodesksavetowebandmobile.msi

For Revit:

  • PACR.msi.

  • FormItConverter.msi

For AutoCAD:

  • webfileopen.msi.

For Navisworks:

  • roamer.msi.

 

Environment:

Windows

Causes:

  • Corrupted registry keys.
  • Visual C++ Missing or Corrupted.
  • Corrupted registry keys may be found using the Microsoft Program Install and Uninstall troubleshooter.

Solution:

Corrupted registry keys

Warning:
Problems caused by improperly editing the Windows registry could render your computer operating system unusable. Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft knowledge base. Use the Microsoft Registry Editor only at your own risk and only after backing up the registry as outlined for your operating system in the Microsoft article. How to back up and restore the registry in Windows and in the related solution. How to back up the system registry. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.

 

  1. Open, as Administrator, the Windows Registry by typing “Regedit” on the Windows Start button.
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products.
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products to remove MSI
  1. Go on “Edit” and search for the missing *.msi file that was called out in the error message. 
  2. Export the SourceList key to create a backup.
  3. Delete the SourceList key that you have found.
  4. Run the Autodesk software installation again. 


Visual C++ Missing or Corrupted

Uninstall and reinstall all Microsoft Visual C++ Components from the Control Panel.
Refer to: How to remove and reinstall Microsoft Visual C++ Redistributables packages.


Corrupted registry keys may be found using the Microsoft Program Install and Uninstall troubleshooter

Use the Microsoft Program Install and Uninstall troubleshooter to uninstall the faulty feature/component if it cannot be uninstalled or deleted from the registry.

 

Products:

All Desktop Products;


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