„Die aktuelle Konstruktionsansichtsdarstellung ist gesperrt. Änderungen werden nicht gespeichert.“ wird beim Speichern einer Inventor-Datei angezeigt.

Autodesk Support

12. Dezember 2024


Abgedeckte Produkte und Versionen


Problem:

Beim Speichern einer geänderten Inventor-Bauteil- oder -Baugruppendatei wird die folgende Meldung angezeigt:

Die aktuelle Konstruktionsansichtsdarstellung ist gesperrt, und die von Ihnen vorgenommenen Änderungen an der Darstellung werden nicht gespeichert. Wenn Sie Ihre Änderungen beibehalten möchten, klicken Sie auf „Abbrechen“, und erstellen Sie eine neue Konstruktionsansichtsdarstellung, oder heben Sie die Sperrung der aktuellen Konstruktionsansichtsdarstellung auf. Klicken Sie zum Fortfahren und Verwerfen der Änderungen an der gesperrten Darstellung auf „OK“.


Fehlermeldung wird in Inventor angezeigt  
Beispiel für eine Fehlermeldung in Inventor 

Außerdem wird ein Sperrsymbol vor dem Namen des Bauteils angezeigt, das Sie überarbeiten möchten:

Fehlermeldung für die Darstellungsansicht 

Ursachen:

Wenn eine Konstruktionsansichtsdarstellung gesperrt ist, können Sie keine Änderungen an den folgenden Elementen darin speichern:

Baugruppenelemente:

  • Komponentensichtbarkeit (sichtbar oder verdeckt)
  • Komponententransparenz
  • Sichtbarkeit von Skizzierelementen, wenn der Sichtbarkeitsstatus durch den Befehl „Objektsichtbarkeit“ gesteuert wird (Der Sichtbarkeitsstatus wird nicht erfasst, wenn die Skizze im Browser aktiviert oder deaktiviert wird)
  • Sichtbarkeit von Arbeitselementen (sichtbar oder nicht sichtbar)
  • Komponentenauswahlstatus (aktiviert oder nicht aktiviert)
  • In der Baugruppe angewendete Darstellungs- und Stilmerkmale
  • Vergrößerung (Zoom)
  • Ansichtswinkel
  • Bauteilansichtsdarstellungen
Teilelemente:
  • Körperdarstellung
  • Skizzensichtbarkeit
  • Skizzenblock-Sichtbarkeit
  • Sichtbarkeit von Arbeitselementen
  • BKS-Sichtbarkeit
  • Browser-Erweiterungsstatus
  • Vergrößerung (Zoom)
  • Ansichtswinkel

Lösung:

Beim Arbeiten in der Baugruppenumgebung:

Die Lösung hängt davon ab, ob Sie die Überschreibungen beibehalten möchten, die Sie an einem oder mehreren der oben aufgeführten Baugruppen- oder Bauteilelementen vorgenommen haben.

  • Wenn Sie die von Ihnen vorgenommenen Überschreibungen nicht beibehalten möchten, klicken Sie im Meldungsdialogfeld auf OK. Die Überschreibungen werden nicht in der aktiven Ansicht gespeichert, es werden jedoch alle Geometrieänderungen gespeichert.
Anmerkung: Ein aktiviertes Kontrollkästchen zeigt die aktive Konstruktionsansicht an, im folgenden Beispiel „RedCubes“.
  • Wenn Sie die von Ihnen vorgenommenen Überschreibungen beibehalten möchten, klicken Sie im Meldungsdialogfeld auf Abbrechen. Sie müssen die Sperrung der Konstruktionsansicht aufheben oder eine neue erstellen, in der Sie die Überschreibungen speichern möchten:
So entsperren Sie eine Ansicht So fügen Sie eine neue Ansicht hinzu 
 

Anmerkung: Die Hauptansicht ist immer gesperrt und kann nicht entsperrt oder gelöscht werden. Daher können Elemente in dieser Ansicht auch nicht überschrieben werden. Wenn die Hauptansicht aktiv ist, müssen Sie entweder eine neue Konstruktionsansicht erstellen oder eine nicht gesperrte Konstruktionsansicht aktivieren, in der Sie die Änderungen speichern möchten:

So fügen Sie eine neue Ansicht hinzu So aktivieren Sie die Ansicht 


Weitere Informationen über Konstruktionsansichten enthält das Video über Konstruktionsansichten in Inventor der Autodesk Virtual Academy.
 

Beim Arbeiten in der Bauteilumgebung:

  • In der Bauteilmodellumgebung wird die Eingabeaufforderung angezeigt, da die grafische Schnittansicht als Überschreibung der Konstruktionsansicht betrachtet wird. Die primäre (Haupt-)Konstruktionsansicht ist immer gesperrt, und die Überschreibung kann nicht gespeichert werden. 
  • Um dieses Problem zu beheben, können Sie die Vorlage so ändern, dass die gesperrte Ansicht nicht die Vorgabe ist. Arbeiten Sie stattdessen in den Ansichten, die entsperrt werden können, um dieses Problem zu verhindern.

 

 

Produkte:

Inventor-Produkte;


Waren diese Informationen hilfreich?


Benötigen Sie Hilfe? Fragen Sie den Autodesk-Assistenten!

Der Assistent hilft Ihnen dabei, Antworten zu finden oder einen Mitarbeiter zu kontaktieren.


Welche Supportstufe haben Sie?

Verschiedene Abonnementverträge bieten unterschiedliche Supportkategorien. Finden Sie heraus, welche Supportstufe Ihr Vertrag unterstützt.

Supportstufen anzeigen