„Datei wurde nicht gespeichert“ in Revit, nachdem erstes Speichern erfolgreich war

Autodesk Support

13. November 2024


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Problem:

"Datei wird in Revit nicht gespeichert", nachdem das erste Speichern erfolgreich war.

Im Revit--Protokoll wird möglicherweise die folgende Zeile aufgezeichnet, die dem Fehler vorangeht:
DBG_WARN: Fehler beim Öffnen der temporären Datei während des Übernehmens: Zeile 351 von D:\Schiff\2020_px64\Quelle\Revit\PersistenceDB\ModelStorage\savetotemporaryfile.cpp
 DBG_WARN: Failed to open temporary file during commit.: line 351 of d:\ship\2020_px64\source\revit\persistencedb\modelstorage\savetotemporaryfile.cpp

Ursachen:

Drittanbieteranwendung, die mit temporären Revit-Dateien interagiert

Lösung:

Deaktivieren Sie zunächst alle Software/Dienste, die bzw. die möglicherweise mit den temporären Revit-Dateien interagieren. Dazu gehören beispielsweise:
  • Antivirensoftware
  • Antischadsoftware
  • Live backup
Wenn das Verhalten durch die Deaktivierung der potenziellen bekannten Software/Dienste nicht behoben wird, führen Sie die folgenden Schritte durch, um den Drittanbieterdienst zu finden, der dieses Problem verursacht:
  1. Laden Sie Microsoft Process Monitor herunter. Informationen zur Verwendung dieses Tools finden Sie im Artikel: So verwenden Sie Sysinternals Process Monitor zur Fehlerbehebung
  2. Da in der Prozessüberwachung viele Daten erfasst werden, nehmen Sie folgende Anpassungen vor:
    1. Deaktivieren Sie "Registrierungsaktivität anzeigen".
    2. Deaktivieren Sie "Netzwerkaktivität anzeigen".
    3. Deaktivieren Sie "Prozess- und Thread-Aktivität anzeigen".
    4. Deaktivieren Sie "Profilerstellungsereignisse anzeigen".
    5. Filter festlegen: Prozessname wird Revit.exe dann ausschließen
    6. Filter festlegen: Pfad enthält C:\Benutzer\%BENUTZERNAME%\AppData\Local\Temp (ersetzen Sie dies durch den Pfad zum Windows-Temp-Ordner des Benutzers) und dann Einschließen.
  3. Anmerkung: Mit den oben genannten Anpassungen sollte die Prozessüberwachung nur Dateisystemaktivitäten anzeigen, bei denen ein anderer Prozess als Revit auf den Windows-Temp-Ordner des Benutzers zugreift.
  4. Die Prozessüberwachung erfasst weiterhin viele Informationen. Um dies zu minimieren, bereiten Sie Revit zum Speichern vor, und bereiten Sie die Prozessüberwachung für die Erfassung mit leerem Protokoll vor.
  5. Starten Sie die Erfassung in Process Monitor, und starten Sie so schnell wie möglich den Speichervorgang in Revit.
  6. Wenn der Fehler auftritt, beenden Sie die Erfassung in Process Monitor so schnell wie möglich. (Sie müssen den Fehler in Revit nicht schließen, bevor Sie die Erfassung im Prozessmonitor beenden.)
  7. Überprüfen Sie die Ergebnisse der Erfassung auf alle Prozesse, die auf temporäre Revit-Dateien zugreifen (diese können wie folgt angezeigt werden: \revitsavetemp##)
  8. Wenn vorhanden, deaktivieren Sie den identifizierten Prozess/Dienst und versuchen Sie es erneut.
Nachdem Sie die Software bzw. den Dienst identifiziert haben, die/der den Fehler verursacht, suchen Sie nach Optionen, mit denen Sie den Zugriff auf temporäre Revit-Dateien durch die Software/den Dienst ausschließen oder die Software/den Dienst deaktivieren können, damit Revit Modelle speichern kann.

Weitere Informationen finden Sie unter:

Revit-Fehler "Datei wurde nicht gespeichert"

Produkte:

Revit;


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