Wie validiert Vault eine Datei?

Autodesk Support

2. Oktober 2024


Abgedeckte Produkte und Versionen


Problem:

Wie "validiert" Vault eine Datei im Dateispeicher? Manchmal sieht es so aus, als würden Dateien im Vault-Dateispeicher fehlen. Wie wird festgestellt, dass sie noch existieren?

Wie kann in Vault eine Liste der Dateien und Versionen erstellt werden, deren Validierung fehlschlägt?

Gibt es einen Prozess, mit dem Einträge aus der Datenbank entfernt werden können, um sie mit dem Dateispeicher zu synchronisieren?

Ursachen:

  • Entfernen von Datenbankeinträgen für Dateien, die nicht mehr existieren
  • Ermitteln, welche Dateien nicht validiert werden können, damit sie aus dem Backup wiederhergestellt werden können

Lösung:

  • Eine Prüfsumme ist eine Zahl, die jedes Mal generiert wird, wenn eine Datei gespeichert oder geändert wird. Es handelt sich um Daten, die in der Datei selbst gespeichert sind. Wenn eine Datei in Vault eingecheckt wird, wird die Prüfsumme aus der Datei gelesen und in der Datenbank gespeichert. Oder man könnte sagen, dass die Prüfsumme beim Einchecken aus der Datei indiziert wird.
  • "Wenn Vault eine Datei "validiert"", liest es die Prüfsumme aus der Datenbank und versucht auch, diese aus der Datei im erwarteten Dateispeicherort zu lesen." Wenn die Datei am erwarteten Speicherort fehlt, schlägt die Überprüfung fehl. Wenn sich die Prüfsumme im erwarteten Dateispeicherort von der in der Datenbank gespeicherten Prüfsumme unterscheidet, schlägt die Prüfung fehl.
  • Wenn sich die Datei am erwarteten Speicherort befindet, öffnen Sie sie in der Erstellungs-/Bearbeitungsanwendung. Manchmal werden Fehlermeldungen angezeigt, wenn die Datei geöffnet oder neu erstellt wird.
  • Wenn ein Tresor gesichert oder wiederhergestellt wird, wird eine Prüfsummenüberprüfung ausgelöst. Prüfsummenvalidierungen können auch während anderer Vault-Vorgänge wie der Dateireplikation oder sogar bei Einzeldateivorgängen wie dem Vorgang Abrufen vom Vault Client oder beim Bearbeiten von Eigenschaften erfolgen.
  • Um festzustellen, welche Dateien nicht validiert werden können, führen Sie eine ADMS-Sicherung mit der Option zur Überprüfung des Dateispeichers aus. Alle Dateien, die nicht validiert werden können, werden in den AVFS-Protokollen aufgeführt.
  • Um Einträge aus der Datenbank für Dateien zu entfernen, die nicht validiert werden konnten, löschen Sie entweder die Dateien in Vault, oder bereinigen Sie die Dateien mit Vault Client.

Produkte:

Vault Workgroup; Vault Professional; Vault Basic


Waren diese Informationen hilfreich?


Benötigen Sie Hilfe? Fragen Sie den Autodesk-Assistenten!

Der Assistent hilft Ihnen dabei, Antworten zu finden oder einen Mitarbeiter zu kontaktieren.


Welche Supportstufe haben Sie?

Verschiedene Abonnementverträge bieten unterschiedliche Supportkategorien. Finden Sie heraus, welche Supportstufe Ihr Vertrag unterstützt.

Supportstufen anzeigen