Autodesk Desktop Connector kann nicht über Microsoft SCCM aktualisiert werden, da CustomAction CleanNamespaceDLLS fehlschlägt.

Autodesk Support

8. Oktober 2023


Abgedeckte Produkte und Versionen


Problem:

Sie versuchen, Autodesk Desktop Connector mithilfe von Microsoft Endpoint Configuration Manager (früher System Center Configuration Manager oder SCCM) auf eine neue Version zu aktualisieren, doch die Einrichtung kann nicht installiert werden. 
 

Ursachen:

Beim Prüfen der Datei CDX_2017_install.log wird eine Fehlermeldung ähnlich der folgenden angezeigt:
Calling custom action CustomActions!CustomActions.CustomActions.CustomAction_CleanNamespaceDLLS
Killing explorer: 21288
Exception caught: Zugriff verweigert
   bei System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
   bei System.Diagnostics.Process.GetProcessHandle(Int32 access, Boolean throwIfExited)
   bei System.Diagnostics.Process.Kill()
   bei CustomActions.CustomActions.CustomAction_CleanNamespaceDLLS(Session session)
CustomAction CleanNamespaceDLLSCustomAction returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (84:64) [11:12:51:635]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.
Action ended 11:12:51: InstallFinalize. Return value 3.
The issue is related to CustomAction_CleanNamespaceDLLS not able to terminate the process explorer.exe during the uninstall

Lösung:

Um das Problem zu beheben, führen Sie die folgenden Schritte nacheinander durch:
Anmerkung: Wenden Sie sich an Ihren Systemadministrator, um die folgenden Vorschläge zu implementieren.
  • Der Benutzer muss alle Datei-Explorer-Fenster schließen, bevor die Installation über das Software Center durchgeführt wird.
  • Führen Sie die Installation über einen Administrator anstelle von System Account aus.
  • Ändern Sie das Skript, um explorer.exe vor dem Ausführen der Installation zu beenden und explorer.exe nach Abschluss der Installation neu zu starten. Stellen Sie sicher, dass das Skript beendet wird und den Vorgang für alle Benutzer (nicht nur für den installierenden Benutzer) neu startet.

Produkte:

Desktop Connector;


Waren diese Informationen hilfreich?


Benötigen Sie Hilfe? Fragen Sie den Autodesk-Assistenten!

Der Assistent hilft Ihnen dabei, Antworten zu finden oder einen Mitarbeiter zu kontaktieren.


Welche Supportstufe haben Sie?

Verschiedene Abonnementverträge bieten unterschiedliche Supportkategorien. Finden Sie heraus, welche Supportstufe Ihr Vertrag unterstützt.

Supportstufen anzeigen