Cursor is slow, jumpy, or jerky in AutoCAD-based products

Autodesk Support

Mar 19, 2025


Products and versions covered


Issue:

Users reported that when moving the mouse cursor across a drawing in AutoCAD, it pauses repeatedly instead of moving smoothly over the screen. The cursor seems jumpy or jerky and may even blink or flash. It might also happen that it freezes.

Causes:

  • Status Bar Autowrap is on.
  • Grids snap enabled in AutoCAD.
  • Mouse (or other input devices) is malfunctioning.
  • Outdated graphics driver.
  • AutoCAD is using the wrong graphics card. 
  • Missing AutoCAD updates.
  • Graphical hardware acceleration is disabled in AutoCAD.
  • Corrupted dwg file.
  • Corrupt User Settings.

Solution:

Click here: Troubleshooting Guide "Cursor is slow, jumpy, or jerky in AutoCAD-based products"

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Alternatively do one or more of the following to improve cursor movement in AutoCAD.

General troubleshooting 

Verify the System Requirements and that AutoCAD Updates are installed.

  1. Does the computer meet the System Requirements for AutoCAD?
  2. Have all available updates* for AutoCAD been installed? Updates can be installed from the Autodesk Account or by checking the Autodesk Desktop App.

*Regardless of how long an AutoCAD release has been available, updates to the application will always require a separate install.

File Specific Troubleshooting

Determine whether the problem is caused by a specific AutoCAD drawing.

  • Disable Grid Snap. See: To Turn On Grid Snap and Set the Snap Spacing | AutoCAD.
    1. Several layouts and the model tab of the same drawing might have different settings. Look for them all.
  • Turn off status bar autowrap (only possible until version 2023)
    1. Right-Mouse click over either the 'Model' tab or a 'Layout' tab and select 'Dock Above Status Bar' or 'Dock in line with Status Bar'.
    2. On the command line type STATUSBARAUTOWRAP.
    3. Select 'OFF' to toggle it off.
    4. Then 'Enter' to end command.
  • Slow performance may be related to drawing corruption or graphic problems with a specific file. See Troubleshooting poor performance with specific drawings in AutoCAD.

Hardware Troubleshooting

  • Confirm that the input device is working properly. See: Troubleshooting the Mouse or Pointing Device used with AutoCAD.
  • If the system is connected to a docking station disconnect all peripherals from the docking station and then test AutoCAD. Check that the graphics card of the docking station is sufficient to support the monitors and other peripherals.

Try to improve graphics performance 

Complex drawings make extensive use of the graphics engine in AutoCAD, sometimes resulting in poor performance. Try to improve performance look for the solutions of this article:

Identify conflicts with Windows OS (Operating System) updates, third-party software, or system utilities

Windows OS updates, Antivirus programs, biometric security products (such as Digital Persona), other security software, or system utilities can conflict with AutoCAD. 

  • Determine whether the problem appeared after an operating system update. See: Troubleshooting poor AutoCAD performance after an Operating System update. Test for a conflict with antivirus software by adding acad.exe to the antivirus exclusion list. If this does not solve the problem, disable or uninstall the antivirus software.

  • Perform a diagnostic Windows startup to allow AutoCAD to run in a clean environment. This may help identify the conflicting program. For more information, see Use Windows diagnostic mode to troubleshoot issues with Autodesk software.

  • If using a monitor or monitors make sure that the main device has sufficient specs to support the monitors graphics.

  • For systems other than Windows XP, disabling BitLocker may solve the problem. To learn more, see BitLocker Drive Encryption. Note: If using VMware Fusion, check settings which may interfere with mouse performance.

Application Troubleshooting

The problem can be caused by a corrupt AutoCAD user profile or a faulty AutoCAD installation.  Try the following solution in this order:

  1. How to reset AutoCAD to defaults

  2. Clean uninstall of AutoCAD or verticals

Products:

AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;


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