"Application does not support just-in-time (JIT) debugging" when launching AutoCAD Products

Autodesk Support

Apr 23, 2024


Products and versions covered


Issue:

When launching an AutoCAD products, it freezes and generates the error:  

AutoCAD

Application does not support just-in-time (JIT) debugging. Contact the application author for more information.

Causes:

Just-In-Time debugging is a feature that launches the Visual Studio debugger automatically when a program, running outside Visual Studio, encounters a fatal error. Just-In-Time debugging allows to examine the error before the application is terminated by the operating system. The Visual Studio debugger does not need to be running when the error occurs.

Solution:

If the Visual Studio is installed

Enable/disable Just-In-Time debugging in Microsoft Visual Studio.

  1. Go to 'Tools' then 'Options'.
  2. In the 'Options' dialog box, select the 'Debugging' folder.
  3. In the 'Debugging' folder, select the "Just-In-Time" page.
  4. In the 'Enable Just-In-Time' debugging of these types of code box, select or clear the relevant program types: 'Managed', 'Native', or 'Script'.
Note:  To enable or disable Just-In-Time debugging, must be running running Administrator privileges.  Enabling or disabling Just-In-Time debugging utilizes the registry key, and Administrator privileges are required to change that key.
  1. Click 'OK'.  

If the Visual Studio is not installed

Disable script debugging in Microsoft Internet Explorer then check if the pop-up is eliminated.

  1. Open 'Internet Explorer'. 
  2. Click on 'Tools' then 'Internet Options' then the 'Advanced' tab. 
  3. Under the 'Browsing' section, uncheck the following:
    • Disable script debugging (Internet Explorer).
    • Disable script debugging (Other).
    • Display a notification about every script error.

Note: More information on JIT debugger and how to enable/disable the Just-In-Time debugging. See Just-In-Time Debugging in Visual Studio

If disabling Just-In-Time Debugging does not resolve the issue

  • If there is any document security program associated with AutoCAD, reinstall it. 
  • Examine the exception error more closely to discover which application the exception is being thrown and the troubleshooting directions the error gives.
  • If an error of "Fatal Error: Unhandled e0434352h Exception at... " occurs with the JIT error, do the following troubleshooting steps. See "FATAL ERROR: Unhandled e0434352h Exception at..." when starting AutoCAD products.
  • Uninstall then reinstall the application for AutoCAD products. See Recommended uninstall and reinstall procedures for AutoCAD.
  • For non-Autodesk (third party) components or add-ons, contact the author of that application for further assistance. For example, the exception may be seen with Microsoft .NET or third party add-ins installed in the AutoCAD product.

Products:

AutoCAD Products;


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