"File not saved" when saving a project file in Revit

Autodesk Support

Mar 12, 2025


Products and versions covered


Issue:

Users reported that when saving a file in Revit fails and results in the following message: 

Revit

File not saved.

File not saved.png

The 'File not saved' issue occurs on one workstation / installation rather than a whole group and the symptoms are as follows:

  • It is intermittent and occurs on a particular workstation.
  • It is reproducible while saving to both network and local folders.
  • It is happening with all file types; new and existing.
  • There may also be the inability to print. Printing from Revit results in a "File not printed" message.

Causes:

Third-party software or services that conflict with the saving process of Revit.

Solution:

Update Revit

Use the steps from the following article to ensure Revit is updated: How to keep Revit updated.

3rd Party Conflict

Go through the steps in the following article to put the system into a simplified startup environment, and check if the issue is cleared: Use Windows diagnostic mode to troubleshoot issues with Autodesk software.

Disable add-ons

Revit add-ons might also create this behavior. Hence removing these can avoid this behavior. See Check if add-ons are causing unexpected behavior in Revit.

Products:

Revit Product Family;


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