"File not saved" in Revit after first save is successful

Autodesk Support

Nov 13, 2024


Products and versions covered


Issue:

"File not saved" in Revit after first save is successful.

The Revit journal may record the following line preceding the error:
DBG_WARN: Failed to open temporary file during commit.: line 351 of d:\ship\2020_px64\source\revit\persistencedb\modelstorage\savetotemporaryfile.cpp
 DBG_WARN: Failed to open temporary file during commit.: line 351 of d:\ship\2020_px64\source\revit\persistencedb\modelstorage\savetotemporaryfile.cpp

Causes:

Third party application interacting with Revit temporary files

Solution:

First, try disabling any software/service that could potentially be interacting with the Revit Temp files, these could include:
  • Antivirus
  • Antimalware
  • Live backup
If disabling the potential known software/services does not clear the behavior, go through the following steps to confirm/find the third party service which is causing this issue:
  1. Download the Microsoft Process Monitor. For information on using this tool, see the article: How to use Sysinternals Process Monitor for Troubleshooting
  2. As the process monitor will capture a lot of data, make the following adjustments to what is being captured:
    1. Turn off “Show Registry Activity”.
    2. Turn off “Show Network Activity”.
    3. Turn off “Show Process and Thread Activity”.
    4. Turn off “Show Profiling Events”.
    5. Set Filter: Process Name is Revit.exe then Exclude
    6. Set Filter: Path Contains C:\Users\%USERNAME%\AppData\Local\Temp (replace this with the path to the user’s Windows temp folder) then Include
  3. Note: With the adjustments above, the process monitor should show only file system activity, where the user’s Windows Temp folder is being accessed by a process other than Revit.
  4. The Process monitor will still capture a lot of information, to minimize this, get Revit ready to save, and get the Process monitor ready to capture with the log cleared.
  5. Start the capture in the Process Monitor and as quickly as possible, start the save operation in Revit.
  6. When the error is encountered, stop the capture in the Process Monitor as quickly as possible (you do not need to dismiss the error in Revit before stopping the capture in the Process Monitor).
  7. Review the results of the capture for any processes accessing Revit temp files (these can show up like … \revitsavetemp##)
  8. When found, disable the process/service identified, and retest.
Once the software/service causing the error is identified, check for options to exclude Revit temporary files from being accessed by the software/service, or keep the software/service disabled to allow Revit to save models.

Products:

Revit;


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