Slow performance and freezes working in any workspace in Autodesk Fusion

Autodesk Support

Mar 7, 2025


Products and versions covered


Issue:

Users reported that Fusion has performance issues, including sluggish/unstable (freezing) behavior, "Not responding" may appear, and calculations/commands hang when working in various workspaces.

These performance issues may be seen during any of the following:

  • Opening, saving, and exporting files.
  • Accessing the Data Panel.
  • Orbiting, Panning, Zooming. 
  • Working in sketches, including creating and managing new or projected geometry. 
  • Computing features in the timeline.
  • Updating components or using the "Get latest" command.
  • Creating a Section Analysis.
  • Programming, regenerating, or renaming CAM toolpaths.
  • Using CAM libraries, such as the Tool, Machine, or Posts library. 
  • Switching between open tabs or workspaces.
  • Minimizing Fusion or switching to another open program window. 

Causes:

Slow performance could be caused by any of the following:

  • Hardware limitations.
  • Network Connectivity issues.
  • AntiVirus blocking the software.
  • Poor modeling habits in the timeline.
  • Graphics drivers not installed/not updated.

Solution:

Confirm that the operating system meets the Autodesk Fusion system requirements

Check if the operating system meets the Autodesk Fusion requirements: System requirements for Autodesk Fusion.

Update, Reset, or Repair Fusion

Check the graphics card drivers


Adjust Fusion display settings for better performance

  • Enable the option to Limit effects to optimize performance
    1. Select the Graphics Diagnostics command from the Help drop-down menu.
    2. Enable (check) the "Limit all effects to provide optimum performance" option. Enabling the option automatically configures the settings and preferences in Fusion for optimal performance at the cost of visual fidelity.

Lower graphic diagnostic in Fusion

  • Disable all the effects in the Display Settings
    1. In the Navigation bar, select Display Settings.
    2. Hover over the Effects tab.
    3. Unmark all the effects settings listed.
Disable effects in the Navigation bar

Adjust preferences for better performance

Go to the preferences and make the following adjustments

  • Go to Data Collection and Use > Disable any analytics. 
  • Go to General > Select the graphics driver option > Test between the available options (DirectX 9, DirectX 11, OpenGL). 
  • Go to Graphics > Set Transparency Effect to Better Performance.

Graphics preferences dialog

  • Go to Graphics > Display > Unmark the High-DPI Application Scaling option.

Display preferences dialog

Deactivate / Update add-ins

Adjust all visual effects for the best performance (Windows)

  1. Open Performance Information and Tools by opening the Control Panel.
  2. In the search box, type Performance Information and Tools.
  3. In the list of results, click Performance Information and Tools.
  4. Click Adjust visual effects. Administrator permission is required. If prompted for an administrator password or confirmation, type the password or provide confirmation.
  5. Click the Visual Effects tab.
  6. Click Adjust for best performance.
  7. Click OK. (For a less drastic option, select Let Windows choose what’s best for my computer).

Check Power options on (Windows)

Check the power options in both the control panel, and settings to verify that there isn't a low-power, energy-saving, or eco mode turned on. 

  1. Check the power mode in the control panel first (if the eco mode is selected here it can limit the power options shown in the 'Settings' menu). See: Change the power mode for your Windows PC
  2. Check the power and sleep settings through the steps here: How to adjust power and sleep settings in Windows.

Antivirus and network connectivity issues

Manual uninstall and reinstall Fusion

See: How to do a manual clean uninstall of Autodesk Fusion

Products:

Fusion;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support