“Installation Incomplete. Some components did not install successfully” when installing 2020 products and above

Autodesk Support

Feb 14, 2025


Products and versions covered


Issue:

When installing Maya 20XX on Windows, the installation fails and the following error is shown:

Installation incomplete
Some components did not install successfully, but basic Autodesk Maya 20XX functions are available.



Maya install error


Maya 2020 Install Incomplete Error  

When installing AutoCAD LT 2022 on Windows, the installation fails and the following error is shown:

Installation incomplete error

When installing AutoCAD 2025 on Windows, the installation error is shown:
 

Installation incomplete error
 
 
 

Environment:

Windows

Causes:

  • Some components failed to install

Solution:

  • If Autodesk Product 20XX installer obtained from the Download or Custom Install download methods , try replacing the original pkg.AGS.xml file in the installer package with the attached one:
 
  • The default pkg.AGS.xml file location is C:\Autodesk\Autodesk_Productname_20XX_ML_Windows_64bit_dlm\x86\AGS\


NOTE: Depending on the Internet browser, the attached pkg.AGS.xml file may lose .xml extension or it may be replaced by .zip.  If this occurs rename the downloaded file to pkg.AGS.xml and then replace the original file as mentioned above.
 

  • If some components are unusable or missing, or if the software isn't launching, perform a clean uninstall and reinstall using the following steps:
  1. Download the Microsoft's utility Fix problems that block programs from being installed or removed and run it.
  2. Select Uninstall.
  3. In the list, find Autodesk Product 20XX, select it and and click Next. Follow the steps until the process completes.
  4. Run the utility again and repeat the above steps for each of the following components (if one is missing, move to the next one): For example. Bifrost, Rokoko, Substance, MtoA.
  5. Reinstall Autodesk Product.
  • The older version of Autodesk Hive is running.
  1. Open the Task Manager > Details tab and check if adsk_hive_host.exe is running. 
  2. Terminate the process if yes.
  3. Restart Product installation. 

Attachments:

pkg.xml;

Products:

All Desktop Products;


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