"No se puede instalar. Falta un componente de instalación necesario o está dañado. "Error 3051" al instalar un producto de Autodesk"

Autodesk Support

6 de marzo de 2025


Productos y versiones cubiertos


Problema:

Al intentar ejecutar una actualización en un producto de Autodesk, la instalación falla y aparece el siguiente mensaje:
 

No se puede instalar

Falta un componente de instalación necesario o está dañado.
Error 3051
 

No se puede instalar: un componente de instalación necesario no se encuentra o está dañado. Error 3051
 
 

Causas:

  • Se intenta instalar una actualización cuando la versión principal del software no está instalada.

  • Versión anterior no admitida de Autodesk Installation Service.

  • Autodesk Installation Service no está instalado en el sistema o si los archivos binarios de servicio se han dañado.

Solución:

Se intenta instalar una actualización cuando la versión principal del software no está instalada

  • Antes de aplicar cualquier actualización, compruebe si la versión principal del software que intenta instalar ya está instalada en el sistema.

  • Si el software está instalado, intente desinstalarlo y volver a instalarlo para hacer una especie de "reparación" de la instalación que podría haberse dañado de alguna manera.  

Versión anterior no admitida de Autodesk Installation Service

En Windows:
 

  1. Descargar AdODIS-installer.exe.
  2. Vaya al directorio ODIS. Verás AdODIS-installer.exe.
  3. Haga clic con el botón derecho en AdODIS-installer.exe y seleccione Ejecutar como administrador para iniciar el asistente de instalación.
  4. Haga clic en Siguiente en el asistente Configuración.
  5. "Lea el acuerdo de licencia y seleccione """"I accept the agreement"""" (Acepto el acuerdo)."
  6. Haga clic en Siguiente para comenzar la instalación.
  7. Haga clic en Finalizar una vez finalizada la instalación.

 

En macOS:
 

  1. Descargar Darwin.dmg
  2. Haga doble clic en el archivo DMG . Verás el AdODIS-installer.app.
  3. Abra Terminal y escriba:

    cd /Volumes/Darwin/AdODIS-installer.app/Contents/MacOS
  4. Tipo:

    sudo ./installbuilder.sh
  5. Introduzca la contraseña cuando se le solicite.

  6. Si el sistema solo permite la instalación de aplicaciones desde la App Store y desarrolladores identificados, es posible que aparezca el siguiente mensaje. Haga clic en Aceptar para cerrar la ventana. 

El

Para cambiar la configuración, lleve a cabo los siguientes pasos:

  1. En el menú Apple , seleccione Preferencias del Sistema

  2. Seleccione Seguridad y privacidad

  3. Haga clic en Abrir de todos modos.

  1. Se abre el asistente de configuración de los servicios de instalación a petición de Autodesk.

  2. Haga clic en Siguiente.

  3. "Lea el acuerdo de licencia y seleccione """"I accept the agreement"""" (Acepto el acuerdo)."

  4. Haga clic en Siguiente para comenzar la instalación.

  5. Haga clic en Finalizar una vez finalizada la instalación.

 

En Linux:
 

  1. Descargue instalador de AdODIS desde cualquier navegador, por ejemplo, Firefox.
Nota. Si tiene problemas durante la descarga, pruebe a utilizar el siguiente comando:
curl -o AdODIS-installer.run https://emsfs.autodesk.com/utility/odis/1/installer/latest/AdODIS-installer.run
  1. Ejecute AdODIS-installer.run en el modo sudo.

    sudo /AdODIS-installer.run

    Nota: Proporcione un permiso ejecutable si AdODIS-installer.run no tiene uno.

  2. Introduzca la contraseña cuando se le solicite.

  3. Se abre el asistente de configuración de los servicios de instalación a petición de Autodesk.

  4. Haga clic en Adelante.

  5. "Lea el acuerdo de licencia y seleccione """"I accept the agreement"""" (Acepto el acuerdo)."

  6. Haga clic en Reenviar para comenzar la instalación.

  7. Haga clic en Finalizar una vez finalizada la instalación.

 

Autodesk Installation Service no está instalado en el sistema o si los archivos binarios de servicio se han dañado

  1. Realice una desinstalación limpia como se indica aquí: Cómo realizar una desinstalación limpia de productos de Autodesk en Windows.

  2. Descargue una nueva copia del producto de Autodesk y ejecute la instalación y las actualizaciones del producto. 

 
 

Productos:

Todos los productos de escritorio;


¿Le ha resultado útil esta información?


¿Necesita ayuda? Pregunte al Asistente de Autodesk

El Asistente puede ayudarle a encontrar respuestas o ponerle en contacto con un agente.


¿Qué nivel de soporte tiene?

Los distintos planes de suscripción ofrecen diferentes categorías de soporte. Averigüe el nivel de soporte para tu plan.

Ver niveles de soporte