¿Cómo se mejora el rendimiento al ejecutar Autodesk Vault con software antivirus?

Autodesk Support

8 de marzo de 2024


Productos y versiones cubiertos


Problema:

  • Se ha producido una degradación significativa del rendimiento con Autodesk Vault y puede deberse al software antivirus.
  • En este artículo se proporciona un consejo general sobre cómo configurar el software antivirus para evitar que afecte al rendimiento de CAD del cliente.

Causas:

  • Normalmente, el software de seguridad (antivirus, prevención de intrusiones/detección) analizará el tráfico de red más entrante y saliente a través de todas las conexiones de red instaladas.
  • Esto puede causar una degradación grave del rendimiento desde la perspectiva del cliente.
  • El rendimiento se puede mejorar mediante la configuración de este software de seguridad para excluir determinados tipos de archivo, procesos y puertos de cualquier análisis.

Solución:

Prueba rápida
  • Desactive temporalmente todo el software de seguridad en cada nodo de la red que se utiliza para la comunicación entre Vault Client y Server.
  • Esto ayudará a determinar si esta es la causa del problema de rendimiento. Compruebe si el problema del cliente se puede reproducir.
 
Tipos de archivo
Es importante excluir determinados tipos de archivo de la exploración para evitar problemas de rendimiento. Es incluso más importante cuando se utiliza un almacén de archivos remoto, ya que el mismo archivo se explorará varias veces antes de llegar a su destino final.

Por ejemplo, si un archivo se encuentra en un almacén de archivos remoto, cuando un usuario intenta obtener una versión, el software antivirus puede explorar el archivo de la siguiente manera:
  1. Saliente del equipo del almacén de archivos remoto
  2. Entrante al equipo de Autodesk Vault Server
  3. Salida del equipo con Autodesk Vault Server
  4. Entrante al equipo cliente
También puede que se produzca algún tipo de análisis en un enrutador o firewall. Es probable que se mejore el rendimiento si estos archivos se excluyen en cada nodo del recorrido de red.
 
A continuación se muestra una lista de los tipos de archivo almacenados más comunes:
  • .dwg
  • .ipt
  • .iam
  • .idw
  • .ipn
  • .dwf
  • .dwfx
  • .dxf
  • .wdp
  • .xls
  • .xlsx
  • .doc
  • .docx
 
Procesos:
Además de los tipos de archivo almacenados, Autodesk Vault Server/Client ejecuta los siguientes procesos, que pueden ser necesarios para añadirlos a la lista de exclusión de antivirus:

Servidor:
  • aspnet_wp.exe
  • w3wp.exe
  • sqlserver.exe
  • Connectivity.ADMSConsole.exe
  • Connectivity.WindowsService.JobDispatch.exe
  •  DADispacherService.exe
  • DynamoHelperService.exe
  • Todos los archivos *.exe de "C:\Program Files\Autodesk", incluidos todos los subdirectorios
  • Setup.exe durante la instalación o durante toda la carpeta de instalación.
  • El proceso acwebbrowser.exe, que se encuentra aquí: "C:\Program Files (x86)\Common Files\Autodesk Shared\CLM\V7\MSVC14\cliccore\"

Cliente y procesador de trabajos:

  • CefSharp.BrowserSubprocess.exe
  • Connectivity.VaultPro.exe
  • Connectivity.Vault.exe
  • DADispatcherService.exe
  • Connectivity.JobProcessor.Delegate.Host.exe
  • JobProcessor.exe
  • CopyDesign.exe
  • Connectivity.JobProcessor.Delegate.Host.exe
  • VaultInventorServer.exe

Puertos:

Normalmente, los puertos se bloquean o desbloquean mediante un firewall, lo que significa que los clientes no suelen conectarse al servidor. Sin embargo, es posible que algunos programas de seguridad exploren los puertos utilizados por Autodesk Vault Server. Si este es el caso, el puerto por defecto utilizado por Autodesk Vault Server es el mismo puerto que el sitio web por defecto (puerto 80).
 
Nota: Se recomienda encarecidamente no reducir la seguridad en ningún equipo sin una buena razón. Los cambios en la configuración predeterminada del software antivirus se realizan completamente bajo el riesgo del administrador y solo se deben realizar si se comprenden completamente las implicaciones de reducir la seguridad.

Productos:

Vault Workgroup; Vault Professional; Vault Office; Vault Basic;


¿Le ha resultado útil esta información?


¿Necesita ayuda? Pregunte al Asistente de Autodesk

El Asistente puede ayudarle a encontrar respuestas o ponerle en contacto con un agente.


¿Qué nivel de soporte tiene?

Los distintos planes de suscripción ofrecen diferentes categorías de soporte. Averigüe el nivel de soporte para tu plan.

Ver niveles de soporte