"Plug-in Assembly Load Error. The assembly "Autodesk.Max.Wrappers.dll" encountered an error while loading." when starting 3ds Max

Autodesk Support

8 de octubre de 2023


Productos y versiones cubiertos


Problema:

Al iniciar 3ds Max, se recibirá un error de carga de ensamblaje de módulo de extensión (Autodesk.Max.Wrappers.dll) similar al siguiente:

Plug-in Assembly Load Error
The assembly "Autodesk.Max.Wrappers.dll" encountered an error while loading.

It is possible that this error put the application in a bad state. The application will continue
to run, but we recommend quitting the application, removing the plug-in and restarting.

Archivo: C:\Archivos de programa\Autodesk\3ds Max\\bin\assemblies\Autodesk.Max.Wrappers.dll
Error completo: System.Reflection.TargetInvocationException: Exception has been thrown by
the target of an invocation. ---> System.BadImageFormatException: Could not load file
or assembly 'System.Xml, Version=4.0.0.0, CUlture=neutral,
PublicKeyToken=b77a5c561934e089' or one of the dependencies. The module was
expected to contain an assembly manifest.
at Autodesk.Max.Configuration.Load()
at Autodesk.Max.Manager.Initialize()
at Autodesk.Max.Manager.AssemblyMain()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Oject target, Object[] arguments,
Signature sig, Boolean constructor)...
 

Imagen añadida por el usuario

Nota: El mensaje y los componentes mencionados en el error de carga de ensamblaje de módulo de extensión pueden variar en función de la instalación.

Causas:

Entre las causas de este error, se incluyen las siguientes:
  • Una instalación dañada de 3ds Max
  • Conflictos con una instalación reciente de Microsoft .NET Framework
  • Permisos y firewalls de programas de Windows
  • Actualizaciones de Windows.
  • Desinstalación y reinstalación con una desinstalación limpia.

Solución:

La solución final puede requerir una de las siguientes opciones o una combinación de estas:


Desinstale todos los componentes de .NET

Para eliminar estos componentes, siga los pasos descritos en Cómo eliminar y volver a instalar Microsoft .NET Framework.

También puede obtener información sobre este tema en el Centro de descarga de Microsoft.



Añada o edite la variable de sistema PATH

Para añadir o editar la variable de sistema PATH en Windows, realice lo siguiente:
  1. En el menú Inicio de Windows, escriba Panel de control.
  2. Cambie la configuración del Panel de control a Ver por: Iconos pequeños (o Iconos grandes).
  3. Seleccione la opción de sistema.
  4. Haga clic en el vínculo "Configuración avanzada del sistema".
  5. En la ficha Opciones avanzadas, haga clic en el botón "Variables de entorno...".
  6. En la sección Variables de sistema, busque la variable de entorno PATH y selecciónela
  7. Haga clic en Editar. (Si la variable de entorno PATH no existe, haga clic en Nueva).
  8. En el cuadro de diálogo Editar la variable del sistema (o Nueva variable de sistema), añada la siguiente línea:
C:\Program Files\Autodesk\3ds Max \
  1. Reinicie el equipo y compruebe si esto resuelve el problema.



Añada una exclusión del programa Windows Defender

Para añadir una exclusión de Windows Defender para 3ds Max, siga las instrucciones descritas en el artículo de Microsoft Add an exclusion to Windows Security.



Desactive la protección en tiempo real de Windows Defender

Si añadir una exclusión no funciona, pruebe a desactivar temporalmente el escáner en tiempo real de Defender para ver si esto afecta al inicio de 3ds Max.
Si se produce más de un error de carga de ensamblaje de módulo de extensión o si aparecen otros mensajes de error al iniciar el programa, realice una desinstalación limpia de 3ds Max y vuelva a instalar el software.

Este proceso elimina lo siguiente:
  • Componentes principales de la instalación de 3ds Max
  • Archivos temporales
  • Archivos y carpetas remanentes
  • Claves de registro de Windows dañadas
  • Archivos de licencia (si el problema está relacionado con las licencias)



Reemplace el archivo Max.Wrapper.dll

  1. Copie el archivo "Max.Wrapper.dll" desde otro equipo en el que se haya instalado 3ds Max y en el que este funcione correctamente (C:\Archivos de programa\Autodesk\3ds Max 20XX\bin\assemblies). También puede encontrarlo en el archivo del instalador (C:\Autodesk\3ds Max 20XX\x64\max\ADSK\Max20XX\bin\assemblies).
  2. Reemplace el archivo "Max.Wrapper.dll" en el equipo afectado (C:\Archivos de programa\Autodesk\3ds Max 20XX\bin\assemblies).
  3. Vuelva a iniciar 3ds Max para comprobar el resultado.


Realice una desinstalación limpia y vuelva a instalar 3ds Max

Si ninguna de las soluciones anteriores resuelve el problema, siga las instrucciones que aparecen aquí para eliminar 3ds Max y, a continuación, vuelva a instalarlo.
Cómo realizar una desinstalación limpia de productos de Autodesk en Windows
 

Productos:

3ds Max;


¿Le ha resultado útil esta información?


¿Necesita ayuda? Pregunte al Asistente de Autodesk

El Asistente puede ayudarle a encontrar respuestas o ponerle en contacto con un agente.


¿Qué nivel de soporte tiene?

Los distintos planes de suscripción ofrecen diferentes categorías de soporte. Averigüe el nivel de soporte para tu plan.

Ver niveles de soporte