SQLDUMPER.EXE ventana que se abre y se cierra al iniciar o trabajar en Revit o Advance Steel

Autodesk Support

6 de marzo de 2025


Productos y versiones cubiertos


Problema:

Los usuarios informaron que al iniciar o trabajar en Revit o Advance Steel en Windows 11, aparece y desaparece una ventana de solicitud de comando que hace referencia a SQLDUMPER.EXE y desaparece cada 1 o 2 segundos. 

Si lo prefiere, la ventana de Advance Steel puede mostrar la rueda giratoria en bucle, mientras que la ventana de solicitud de comando puede aparecer y desaparecer demasiado rápido para ver su nombre.

 

Pantalla de SQLDUMPER.EXE ventana de solicitud de comando sin contenido, solo título


Al abrir Advance Steel, se abría una pantalla blanca.

Aparece una ventana de solicitud de comando que hace referencia a SQLDUMPER.EXE



 
 

Entorno:

  • Sistema operativo Windows 11.

  • Unidades SSD/NVMe con un tamaño de sector superior a 4KB.

Causas:

  • SQL Server no se puede iniciar debido a que el sistema de archivos no es compatible. SQL Server admite actualmente tamaños de almacenamiento por sector de 512 bytes y 4 KB.

Nota: Una actualización a Windows 11 podría desencadenar este problema en los sistemas de unidades SSD/NVMe con tamaños de sector superiores a 4KB. El problema no estaba presente en versiones anteriores de Windows, ya que los controladores integrados limitaban el valor del tamaño del sector.

  • Microsoft SQL Server 2014 LocalDB (2019 para las versiones 2024 y posteriores) no está instalado correctamente.

  • Hay instalada una versión más reciente que Microsoft SQL Server 2014.

  • Se han restringido los permisos de la carpeta Advance Steel o RVT en ProgramData\Autodesk.

Solución:

Actualización de software

Consulte la siguiente página de soporte para obtener información sobre cómo Actualizar los software.

Investigue el tamaño del sector del disco de almacenamiento mayor que 4 KB:

  • Registro SQL: Compruebe el error.log (en C:\Users\%USERNAME%\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances\{Instance version}) de la siguiente entrada (si se encuentra, indica que el tamaño del sector es demasiado grande): 
    There have been 256 misaligned log IOs which required falling back to synchronous IO

  • Comando FSUTILS: Para comprobar directamente el tamaño del sector, siga estos pasos:
    1. Inicie la solicitud de comandos como administrador y ejecute el siguiente comando:
fsutil fsinfo sectorinfo C:
    1. Busque los valores de PhysicalBytesPerSectorForAtomicity y PhysicalBytesPerSectorForPerformance (que se muestran en bytes). Si alguno de estos valores es mayor que 4096 (como en la imagen adjunta), el tamaño del sector es demasiado grande.

Pantalla de Windows Símbolo del sistema con el resultado de la comprobación del tamaño del sector
 
      1. Descargue y ejecute SetSectorSize.reg (se adjunta en este artículo). De este modo, se añadirá el valor * 4095 al registro.

      2. Reinicie el sistema después de cambiar el Registro de Windows para ver las modificaciones de SectorSize.

Compruebe los permisos de los usuarios y administradores para la carpeta del programa

  1. Busque la carpeta Advance Steel #### o RVT #### en C:\ProgramData\Autodesk

    1. Si no se encuentra la carpeta ProgramData, consulte el siguiente artículo para obtener información sobre Cómo activar los archivos y carpetas ocultos en Windows.

  2. Haga clic con el botón derecho en la carpeta, elija Propiedades y, a continuación, elija la ficha Seguridad

  3. Compruebe si los permisos de usuarios y administradores están configurados para Control total en Permitir

    1. Haga clic en Editar para cambiar los permisos.

    2. Envíe los cambios a través del botón Aplicar.

Investigar daños en SQL

Siga estos pasos para comprobar SQL: Investigación de la instalación de SQLServerLocalDB al trabajar con Advance Steel/Revit.  

Perfil de usuario de Windows

Si los pasos anteriores no borraron el comportamiento, pruebe a iniciar sesión en otro usuario de Windows y compruebe si se produce el mismo comportamiento. Si no es así:

Revertir el sistema operativo a una versión anterior

Si el problema se introdujo al actualizar Windows, regrese a Windows 10 siempre que sea posible. Consulte Opciones de recuperación en Windows.

     

    Archivos adjuntos:

    SetSectorSize.reg;

    Productos:

    Advance Steel; Familia de productos Revit;


    ¿Le ha resultado útil esta información?


    ¿Necesita ayuda? Pregunte al Asistente de Autodesk

    El Asistente puede ayudarle a encontrar respuestas o ponerle en contacto con un agente.


    ¿Qué nivel de soporte tiene?

    Los distintos planes de suscripción ofrecen diferentes categorías de soporte. Averigüe el nivel de soporte para tu plan.

    Ver niveles de soporte