Nothing happens after the “Preparing for installation…” when installing an Autodesk product 2021 or higher

Autodesk Support

Feb 14, 2025


Products and versions covered


Issue:

When trying to install an Autodesk 2021 or higher version, it shows "Preparing for installation..." window but nothing happens after that and the installation doesn't start after the window closes 

Preparing for installation...

Preparing for installation
 

Causes:

  • Permission issues

  • Network restrictions

  • Certificate issues

  • Corrupt ODIS installer

Solution:

To solve the issue set windows permission and run the installation from the Command prompt as per the instructions.

Set windows permissions

Be sure that the following folders have read/write permission:

  • C:\Program Files

  • C:\Program Files (x86)

  • C:\ProgramData

 

From the Command prompt run the installation, Setup.exe.

  1. Go to the Windows Start button.

  2. Type cmd to open Command Prompt and run it as administrator. 

  3. Type the following and press ENTER. 

    cd C:\Autodesk\AutoCAD_2022_English_Win_64bit_dlm\

Note. The path can be different, check first the exact path in C:\Autodesk.

  1. Type the following and press ENTER.

    Setup.exe --noupdate
  2. You should have something like this on Command Prompt and the installation should finally start.

Noupdate Installation

Check Event Logs for possible errors

  1. See: Obtaining Windows Event logs for diagnostics and troubleshooting

  2. This issue can be related to: "Error 2: The system cannot find the file specified." when starting Autodesk Access Service Host


In case there is error 'System exit code 1260' in the Setup.log file:

2022-09-13T15:51:01.516 [Bootstrap: 12932, single] [Bootstrap ERROR] [BS_Setup::ExecuteCommand ]     => Process failed to launch. System exit code  1260

Follow the procedure:

  • Uninstall and Reinstall the ODIS component before installing the software
    1. Go to C:\Program Files\Autodesk\AdODIS\V1.

    2. Run RemoveODIS.exe as administrator.

    3. Remove the contents of folder C:\ProgramData\Autodesk\ODIS\.

    4. Download and install latest version of ODIS .

  • Clear the '%temp%' folder and the '%localappdata%\autodesk\ODIS' folder.
  • Run the installer from an Administrator Command prompt (type 'cmd' in Windows search and 'run as Administrator') with the following command:
"C:\Program Files\Autodesk\AdODIS\V1\Installer.exe" --install_mode install --manifest "C:\Autodesk\AutoCAD_LT_2023_English_Win_64bit_dlm\setup.xml" --manifest_xsd "C:\Program Files\Autodesk\AdODIS\V1\SetupRes\manifest.xsd"  --offline_mode --trigger_point local

 

Update Trusted Certificates

Make sure that all Trusted Certificates are installed and updated in the machine by following the steps in the article: Updating List of Trusted Root Certificates in Windows

 

Products:

All Desktop Products;


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