Autodesk Access shows no sign-in page

Autodesk Support

Feb 19, 2025


Products and versions covered


Issue:

When trying to sign in on Autodesk Access, no sign-in page is shown or it lets you insert the email address but not the password.

Causes:

  • Installation for the Autodesk Identity Manager component might be corrupted.
  • Installation for Autodesk Access might be corrupted.
  • Edge is set as the default browser and won't open some Autodesk web pages like the Autodesk Identity Manager download page. 

Solution:

To solve the issue:

Uninstall and reinstall the Autodesk Identity Manager component

  1. Go to Control Panel and open Programs and Features.

  2. Look for the "Autodesk Identity Manager" component and uninstall it.

  3. Reboot the system.

  4. Download and install the component from here.

Note. If the component doesn't show up in "Programs and Features", remove it by doing the following and then proceed with steps 3 and 4:

  1. Go to C:\Program Files\Autodesk\AdskIdentityManager.

  2. Right-click on "uninstall.exe".

  3. Run the file as Administrator.

Verify that WebView 2 component is installed

Reinstall Autodesk Access

  1. Reboot the system.

  2. Download and install the latest Autodesk Access version from here.


Note: If after all the steps the error “Check your browser” shows up:

  1. Click "Restart sign-in".

  2. Do the Autodesk sign-in.

Change default browser

  1. Set Google as the default browser

  2. Retry to sign in to Autodesk Access

Products:

Autodesk Access;


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