"Error 2: The system cannot find the file specified." when starting Autodesk Access Service Host

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

When starting the ODIS related service, Autodesk Access Service Host, it displays an error message.
'Windows could not start the Autodesk Access Service Host service on Local Computer. Error 2: The system cannot find the file specified.'

"Error 2: The system cannot find the file specified." when starting Autodesk Access Service Host

Causes:

  • Outdated or corrupted Autodesk Installer Service component
  • Files with .exe extension in C:\Program Files\Autodesk\AdODIS\V1\Setup are inaccessible.

Solution:

Uninstall and reinstall Autodesk Installer

  1. Press the Win + R keys.​​​

  2. Type 'services.msc' in the Run window and select 'OK'.
  3. Stop the service 'Autodesk Access Service Host'.
  4. Go to C:\Program Files\Autodesk\AdODIS\V1.
  5. Right click on the 'RemoveODIS.exe' and select run as administrator. If this options is not available, manually delete all the content in the folder.
  6. Download and install the latest version of the Autodesk Installer.
  7. Start the service.
  8. If the issue persists check if files with .exe extension inside the folder 'C:\Program Files\Autodesk\AdODIS\V1\Setup' are accessible. This can be checked by double clicking on each file with extension with exe. if see the error below follow the steps mentioned under Delete Debugger entries in Registry. 

The following error appears:
Windows cannot find 'C:\Program Files\Autodesk\AdODIS\V1\Setup\AdskAccessCore.exe'
Make sure you typed the name correctly, and then try again.

Windows cannot find AdskAccessCore.exe . Make sure you typed the name correctly, and then try again.


Delete Blocked Debugger Values in the registry for the corresponding Autodesk Installer related files

  1. Open Registry Editor(Type regedit in Run and press Enter)

  2. Navigate to the path 'HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution'
  3. Look for all Autodesk keys in the "Image File Execution" folder.
  4. Check if those keys have the Value Name 'debugger' and corresponding Value Data 'Blocked 'If found such value delete it as shown below.
Delete Debugger values
  1. Repeat the same step for all the keys matching with exe extension in the folder 'C:\Program Files\Autodesk\AdODIS\V1\Setup'
List of keys to check for Debugger value

 

Confirm that an antivirus is not blocking Autodesk components

See: How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software

Products:

All Desktop Products;

Versions:

2024; 2022; 2021; 2023; 2025;


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