"License checkout timed out. What do you want to do?" when launching Autodesk product on Windows

Autodesk Support

Feb 11, 2025


Products and versions covered


Issue:

If you are using a Mac click here

Users reported that when starting an Autodesk product on Windows, after several seconds a message such as the following appears and the program must close. The message may also appear after waking up from sleep mode.

Product License - Out of Time

License checkout timed out. What do you want to do?

License checkout timed out. What do you want to do?

 

Environment:

  • Windows 10.

  • Windows 11.

Causes:

  • Autodesk Desktop Licensing Service is not running.

  • Corrupt Licensing Component.

  • Corrupt Single Sign On Component.

  • Incompatible 3rd party software/device.

  • Autodesk Desktop Licensing Service set to run as "This account" in Windows Services.

  • Lack of permission on the ProductInformation.pit.

  • Product license registration incomplete.

  • Proxy or Network Setting.

Solution:

Recommended Solution - Resolve this with the Troubleshooting Tool.

Follow the simple Step-by-step guide in the following link.

Alternatively, try the below suggestions one by one.

 

WatchGuard Panda Adaptive Defense 360 

Some users have reported that Autodesk Desktop Licensing Service stops working when using Panda Adaptive Defense 360/WatchGuard EDPR. Follow these steps from WatchGuard Community to address the issue or alternatively, contact WatchGuard Support for dedicated support.


Uninstall and reinstall the latest Autodesk Desktop Licensing Service

  1. Uninstall the Autodesk Desktop Licensing Service: How to uninstall Autodesk Desktop Licensing Service.

  2. Download and install using the latest version: Autodesk Desktop Licensing Service.

  3. Try again to start your product.


Update the Autodesk Identity Component.

  1. Download and install the latest update for:

  2. Try again to start your product.



Restart or check if the Autodesk Desktop Licensing Service is running

See How to check the status of Autodesk Desktop Licensing Service


Add the Licensing Component to your antivirus exception list

Consult with your IT team or internet security software vendor to set exceptions in your antivirus software for the below folders:

  • C:\Program Files\Autodesk\

  • C:\Program Files\Common Files\Autodesk Shared\

  • C:\Program Files (x86)\Autodesk\

  • C:\Program Files (x86)\Common Files\Autodesk Shared\

  • C:\ProgramData\Autodesk\

  • C:\Users\<username>\AppData\Roaming\Autodesk\

  • C:\Users\<username>\AppData\Local\Autodesk\


Check for known conflicting software

See Autodesk Licensing Service: Known Conflicting Applications.


Autodesk Desktop Licensing Service set to run as "This account" in Windows Services

  1. Type "Services.msc" into the Windows search. 

  2. Navigate to the Autodesk Desktop Licensing Service.

  3. Right-click it and select "Properties".

  4. Select the "Log On" tab.

  5. Change "Log on as:" to "Local System account" and select "Allow service to interact with desktop".

  6. Select the "Apply" button.

  7. Restart the product.


Re-register software with Licensing Service

See How to re-register an Autodesk software with the Autodesk Licensing Service.


Verify user's permissions on Autodesk folders

See that What user permissions does AutoCAD require?

Correct user's permission on the ProductInformation.pit file

  1. Navigate to C:\ProgramData\Autodesk\Adlm.

  2. Right-click on ProductInformation.pit. 

  3. Click on Properties > Security > Advanced.

  4. Click "Enable inheritance" and then OK.

  5. Lauch the software.

Check your proxy and/or firewall

 

 

Products:

All Desktop Products;


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