How to change the assigned ports on an Autodesk license server and client

Autodesk Support

Aug 12, 2024


Products and versions covered


Issue:

How to change the assigned ports 2080 (adskflex vendor daemon) and 27000-27009 (lmgrd master daemon) on an Autodesk license server and client.

Causes:

You have multiple Flexlm based license servers hosted from the same license server.

Solution:

Ports are officially assigned to the FLEXnet license manager for Autodesk products by the Internet Assigned Numbers Authority:
 

Services and related ports:
lmgrd master daemon: 27000-27009
adskflex vendor daemon: 2080
 

If your network is running another application that is using port 2080 and/or 27000–27009, and that application cannot be relocated to another port, it is possible to change the assigned ports to use different ports.

Note: These changes are not officially supported by Autodesk as they may generate conflicts with other applications. We strongly recommend not to change the ports unless it is absolutely necessary.
 

How to change the ports on the server:

To change the ports you have to modify the license file on the server to assign a port number on the SERVER line and assign a different port number on the VENDOR line. For example:

Original license file (first 3 lines):

SERVER Master01 00d0b757050C0
USE_SERVER
VENDOR adskflex port=2080

Modified license file (first 3 lines):

SERVER Master01 00d0b757050C0 27500
USE_SERVER
VENDOR adskflex port=2099

 

How to change the ports on the client:

If you are using ADSKFLEX_LICENSE_FILE environment variable, you can add your license server port in front of @yourservername.

For example:
ADSKFLEX_LICENSE_FILE=27500@Master01 or ADSKFLEX_LICENSE_FILE=2099@Master01.

In addition to modifying the license file you will want to modify the LICPATH.LIC files on the client systems as well.
This is the file that tells the product where to find the license server.
 

On Windows: 
  • For Autodesk software version 2017 and higher, LICPATH.lic file can be found in C:\ProgramData\Autodesk\CLM\LGS\<Product Key>_<Product version>.0.0.F
    • For example for AutoCAD 2019, the file location would be C:\ProgramData\Autodesk\CLM\LGS\001K1_2019.0.0.F
  • For Autodesk software version 2016 and earlier LICPATH.lic file is typically found in the root folder of the Autodesk program, such as C:\Program Files\Autodesk\Civil 3D 2015.
On Mac OS X:
  • For Autodesk software version 2017 and higher, LICPATH.lic file can be found in /Library/Application Support/Autodesk/CLM/LGS/<Product Key>_<Product version>.0.0.F. 
    • For example for AutoCAD 2018 for Mac, the file location would be /Library/Application Support/Autodesk/CLM/LGS/777J1_2018.0.0.F
  • For Autodesk software version 2016 and earlier client license file location usually is in /var/flexlm
  • You can find your license file location in ~/.flexlmrc file. From a terminal run following command cat ~/.flexlmrc, the command will display .flexlmrc file content in the terminal, check for ADSKFLEX_LICENSE_FILE value.
On Linux: 
  • Client license file can be found in several folders most often in /var/flexlm/
  • You can find your license file location in ~/.flexlmrc file. From a terminal run following command cat ~/.flexlmrc, the command will display .flexlmrc file content in the terminal, check for ADSKFLEX_LICENSE_FILE value.
  1. Update the SERVER line of this file by adding the same port number you assigned in the license file:
SERVER Master01 00d0b75705020 27500
USE_SERVER
 
  1. If you do not find the LICPATH.LIC file, you can create a license file by saving a text file with the extension .LIC, and including the following information (found in your license file):
SERVER <HOSTNAME> <HOSTID> <ALTERNATE PORT NUMBER>
USE_SERVER
  1. Confirm that both the client and server are using the same port for the lmgrd master daemon.
  2. Rebooting the system is necessary before your modifications can take effect.

Note. Specifying an alternate port restricts you to only using a single specific port and not a port range.

Products:

All Desktop Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support