Comment réparer ou réinstaller Microsoft .NET Framework

Autodesk Support

18 janvier 2025


Produits et versions couverts


Problème :

Vous souhaitez savoir comment réparer et réinstaller Microsoft .NET Framework pour corriger un problème lié à l’installation ou l’exécution d’un logiciel Autodesk, tel qu'une défaillance générale lors de l'installation (en raison d'un conflit avec les conditions préalables du programme d'installation) ou un comportement anormal ou un blocage au cours d'un fonctionnement normal.

Environnement :

Système d'exploitation Windows (OS) uniquement. Seul le système d'exploitation Windows utilise .NET Framework.

Causes :

  • Pour Windows 8, 10 ou 11
    • Système d'exploitation et .NET Framework obsolètes.
    • La seule méthode consiste à réparer .NET Framework et à exécuter le vérificateur des fichiers système. .NET Framework ne peut pas être désinstallé sous Windows 8, 10 et 11.
  •  .NET Framework peut être réinstallé à partir de Windows 7 et des systèmes d’exploitation antérieurs : il s’affiche dans Programmes et fonctionnalités (Ajout/Suppression de programmes pour Windows XP) dans la liste des programmes installés.

Solution :

Pour Windows 8, 10 ou 11

  1. Mettez à jour le système d'exploitation, il recherchera automatiquement et installera les mises à jour manquantes pour .NET Framework.
  2. Téléchargez et exécutez l’outil de réparation de Microsoft .NET Framework.

Exécutez ensuite le vérificateur des fichiers système :

  1. Lancez l'invite de commande à l'aide de l'option « Exécuter en tant qu'administrateur » de Windows. 
  1. Saisissez la commande « SFC /SCANNOW ».
  2. Attendez la fin de l'opération et consultez le message qui s'affiche :
    • Le message suivant ne signale aucune corruption de .NET : « Le programme de protection des ressources Windows n'a trouvé aucune violation d'intégrité. »
    • Des corruptions ont été réparées si le message suivant s'affiche : « La protection des ressources Windows a trouvé des fichiers endommagés et a pu les réparer. Des détails sont inclus dans le journal CBS.Log %WinDir%\Logs\CBS\CBS.log. » Testez à nouveau le logiciel Autodesk pour voir si le problème est désormais résolu. 
    • Consultez l'article Use the System File Checker tool to repair missing or corrupted system files - Microsoft Support si le message suivant s'affiche : «La protection des ressources Windows a trouvé des fichiers endommagés, mais n'a pas réussi à les réparer. Des détails sont inclus dans le journal CBS.Log %WinDir%\Logs\CBS\CBS.log. » Il peut être nécessaire de réévaluer le système d'exploitation pour résoudre le problème. 

 

.NET Framework peut être réinstallé à partir de Windows 7 et des systèmes d'exploitation antérieurs

Pour les systèmes d'exploitation Windows antérieurs :

  1. Ouvrez Programmes et fonctionnalités dans le Panneau de configuration de Windows (ou Ajout/Suppression de programmes sous Windows XP). Pour accéder facilement à cette fonctionnalité sur les systèmes autres que Windows XP, entrez "programmes et fonctionnalités" dans la zone de recherche du menu Démarrer.
  2. Désinstallez tous les programmes commençant par Microsoft .NET, en commençant par les versions les plus récentes.

  3. Téléchargez et installez la dernière version de l’environnement d’exécution .NET pour le système d'exploitation applicable à partir de : Microsoft .NET Framework.

Produits :

Tous les produits de bureau ;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance