« La représentation de vue de conception actuelle est verrouillée. Les modifications apportées ne seront pas enregistrées. » s’affiche lors de l’enregistrement d’un fichier Inventor

Autodesk Support

12 décembre 2024


Produits et versions couverts


Problème :

Lorsque vous tentez d’enregistrer un fichier pièce ou ensemble Inventor que vous avez modifié, le message suivant s’affiche :

« La représentation de vue de conception actuelle est verrouillée, et les modifications que vous y avez apportées ne seront pas enregistrées. » Si vous souhaitez conserver ces modifications, cliquez sur Annuler et créez une nouvelle représentation de vue de conception ou déverrouillez la représentation actuelle. Pour continuer et ignorer les modifications apportées à la représentation verrouillée, cliquez sur OK.


Le message d’erreur s’affiche dans Inventor  
Exemple de message d’erreur dans Inventor 

Une icône de verrouillage s’affiche également devant le nom de la pièce que vous essayez de réviser :

Message d’erreur pour la vue de représentation 

Causes :

Lorsqu’une représentation de vue de conception est verrouillée, vous ne pouvez pas enregistrer les modifications apportées aux éléments de vue de conception suivants :

Eléments d’assemblage :

  • Visibilité des composants (visibles ou non)
  • Transparence des composants
  • Visibilité de la fonction d’esquisse si l’état de visibilité est contrôlé par la commande Visibilité de l’objet. (Elle ne capture pas l’état de visibilité si l’esquisse est activée ou désactivée dans le navigateur)
  • Visibilité de la fonction de construction (visible ou non)
  • Etat de sélection des composants (activés ou désactivés)
  • Caractéristiques d’apparence et de style appliquées dans l’ensemble
  • Facteur de zoom
  • Angle de visualisation
  • Représentations de vue de pièce
Eléments de pièce :
  • Apparence du corps
  • Visibilité de l'esquisse
  • Visibilité du bloc d'esquisse
  • Visibilité de la fonction de construction
  • Visibilité du SCU
  • Etat de développement du navigateur
  • Facteur de zoom
  • Angle de visualisation

Solution :

Lorsque vous travaillez dans l’environnement d’ensemble :

La solution varie selon que vous souhaitez ou non conserver les remplacements apportés à un ou plusieurs des éléments d’assemblage ou de pièce répertoriés ci-dessus.

  • Si vous ne souhaitez pas conserver les remplacements effectués, cliquez simplement sur OK dans la boîte de dialogue du message. Les remplacements ne seront pas stockés dans la vue active, mais toutes les modifications apportées à la géométrie seront enregistrées.
Note : Une case cochée indique la vue de conception active, comme pour les « RedCubes » dans l’exemple ci-dessous.
  • Si vous souhaitez conserver les remplacements effectués, cliquez sur Annuler dans la boîte de dialogue du message. Vous devez déverrouiller la vue de conception ou en créer une nouvelle dans laquelle enregistrer vos remplacements :
Pour déverrouiller la vue Pour ajouter une nouvelle vue 
 

Remarque : la vue « principale » est toujours verrouillée et ne peut être ni déverrouillée ni supprimée. Par conséquent, les éléments de la vue principale ne peuvent pas être remplacés. Si la vue principale est active, vous devez soit créer une vue de conception, soit activer une vue de conception déverrouillée dans laquelle enregistrer vos modifications :

Pour ajouter une nouvelle vue Activez la vue 


Pour en savoir plus sur les vues de conception, visionnez la vidéo Autodesk Virtual Academy, Vues de conception en Inventor.
 

Lorsque vous travaillez dans l’environnement de pièce :

  • Dans l’environnement du modèle Pièce, l’invite s’affiche, car la vue en coupe graphique est considérée comme un remplacement de la vue de conception. La vue de conception principale (principale) est toujours verrouillée et le remplacement ne peut pas être enregistré. 
  • Pour résoudre ce problème, vous pouvez modifier votre modèle afin que la vue verrouillée ne soit pas la valeur par défaut. Au lieu de cela, travaillez dans les vues qui peuvent être déverrouillées pour éviter que ce problème ne se produise.

 

 

Produits :

Produits Inventor ;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance