Comportement inattendu du texte lors de l'exportation depuis Revit vers un fichier de CAO

Autodesk Support

8 octobre 2023


Produits et versions couverts


Problème :

Les champs de texte avec un symbole tel que +, -, /, etc. sont déplacés ou transposés lors de l'exportation de Revit au format DWG 

Exemples

Image ajoutée par l'utilisateur

+415 123 4567                                                       7654 321 514+

Causes :

Le mécanisme d'exportation crée des styles de texte AutoCAD. Chaque style de texte possède un paramètre nommé "charset" (jeu de caractères).
 
Lors de l'exportation, pour chaque élément de texte, Revit définit le jeu de caractères en fonction des paramètres régionaux de Windows et vérifie si tous les caractères du texte sont dans ce jeu de caractères. Pour notre cas, tous les caractères de "1 : 200" sont dans le jeu de caractères (arabe persan, ourdou, dari, en raison des paramètres régionaux) et c'est pourquoi il est choisi.
 
Dans AutoCAD, un texte avec le contenu "1 : 200" et un jeu de caractères Arabe Perse, Ourdou et Dari (en raison des paramètres régionaux) sera représenté à l'écran comme "200 : 1".
 
Remarque : lors de la création d'un élément de texte dans Revit, la langue du clavier (par exemple, l'anglais) est utilisée et non les paramètres régionaux. C'est pourquoi nous constatons un changement au cours de l'exportation lorsque ces paramètres sont pris en compte.

Solution :

Nos développeurs ont été mis au courant de ce comportement.

Pour empêcher la modification de l'affichage du texte, suivez la procédure ci-dessous :
1. Accédez au Panneau de configuration -> Région et langue -> onglet Administration. 
2. Cliquez sur Modifier les paramètres régionaux du système...
3. Sélectionnez Anglais (au lieu de Arabe Perse, Ourdou, Dari) et redémarrez l'ordinateur.
Image ajoutée par l'utilisateur

Produits :

Famille de produits Revit ;

Versions :

2013; 2014; 2015; 2016;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance