Erreur "Erreur 20 du système de licence" au lancement de Revit

Autodesk Support

8 octobre 2023


Produits et versions couverts


Problème :

Lors de l'exécution de Revit, le message d'erreur suivant s'affiche : "Erreur 20 du système de licence"

"Erreur système de licence 20"

Image ajoutée par l'utilisateur

Causes :

  • Les fichiers de stockage approuvés sont corrompus
  • L'installation de C++ est corrompue
  • L'installation de Revit est corrompue

Solution :

Essayez de modifier ou de réinitialiser les informations de licence en suivant les instructions de l'article ci-dessous : Après avoir suivi la procédure ci-dessus, supprimez les informations de licence stockées dans le système en procédant comme suit :
  • Fermez tous les programmes Autodesk en cours d'exécution.
  • Déconnectez-vous et quittez l'application de bureau Autodesk et A360.
  • Accédez à C:\ProgramData\Autodesk\%00a0 et supprimez le dossier ADUT
  • Accédez à C:\Users\\AppData\Roaming\Autodesk\%00a0 et supprimez le dossier ADUT
  • Supprimez les trois fichiers commençant par adskflex dans C:\ProgramData\FLEXnet. (Remarque : les fichiers peuvent être masqués.)
  • Supprimez le fichier LoginState.xml dans le dossier %LOCALAPPDATA%\Autodesk\Web Services.
  • Redémarrez le logiciel et répétez le processus d'activation.
Essayez ensuite de désinstaller et de réinstaller tous les programmes Microsoft C++
Comment supprimer et réinstaller les bibliothèques Runtime Visual C++ de Microsoft

Si le problème persiste, essayez d'effectuer une désinstallation propre, en supprimant tous les logiciels Autodesk de la section Produits et fonctionnalités du Panneau de configuration et tous les fichiers/dossiers Autodesk décrits dans l'article ci-dessous :

Produits :

Famille de produits Revit ;

Versions :

2017; 2019; 2018;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance