« L’éditeur S&C a rencontré une erreur lors de l’exportation vers Excel » lors de l’exportation dans AutoCAD Plant 3D Spec Editor

Autodesk Support

3 janvier 2025


Produits et versions couverts


Problème :

Lors d’une tentative d’exportation vers Excel à partir d’AutoCAD Plant 3D Spec Editor, la série de messages suivante s’affiche :

Message d’erreur s’affichant lors de l’exportation Excel à partir des spécifications et des catalogues.

Echec de l’exportation vers Excel

L’éditeur S&C a rencontré une erreur lors de l’exportation vers Excel.

Echec de l’exportation vers Excel lors de l’exportation de la spécification des tuyauteries vers Excel.

Causes :

  • Cause 1 : Spécification corrompue
    • Spec Editor se bloque après l’affichage du message d’erreur et doit être fermé à l’aide du gestionnaire des tâches.
  • Raison2 : installation de MSOffice.
    • Version 32bits d’Excel.
    • L’installation de MS Office est corrompue.
  • Raison3 : Fichiers temporaires et mis en cache.
    • Fichiers temporaires et mis en cache obsolètes
  • Raison4 : version2021 sans mises à jour.
    • Problème résolu.

Solution :

Effectuez une ou plusieurs des opérations suivantes :

Raison1 : spécification des tuyauteries corrompue

  1. Ouvrez la spécification des tuyauteries concernée dans AutoCAD Plant 3D Spec Editor.

  2. Copiez tous les composants (STRG+C).

  3. Créez une nouvelle spécification des tuyauteries.

  4. Collez tous les composants dans cette nouvelle spécification des tuyauteries.

  5. Enregistrez la spécification des tuyauteries.

Raison2 : installation de MSOffice

  • Version Excel 32bits

    1. Vérifiez la version en bits de l’installation d’Excel.

      • Image montrant comment vérifier la version et le bit d’Excel.
    2. Installez la version 64bits d’Excel.

  • L’installation de MS Office est corrompue.

    1. Réparez MS Office.

Raison3 : Fichiers temporaires et cache.

  1. Fermez AutoCAD Plant 3D, y compris Spec Editor.

  2. Ouvrez l’Explorateur de fichiers.

  3. Entrez %TEMP% dans la barre de titre et appuyez sur Entrée.

  4. Sélectionnez tout et supprimez tout, ce qui peut être supprimé. Ignorez le reste.

  5. Basculez vers le dossier %LOCALAPPDATA%\Autodesk\Autodesk AutoCAD Plant 3D \Rxy.z\.

  6. Il y a trois dossiers de cache. Supprimez le contenu de ces dossiers.

Raison4 : version2021 sans mises à jour.

  • Ce problème a été résolu dans AutoCAD Plant 3D Update2021.1.

    1. Installez AutoCAD Plant 3D Update2021.1 ou une version ultérieure.

    2. Téléchargez cette mise à jour à partir de votre compte AutodeskAccount.

Version 2025 ou ultérieure :

  • Si aucune des options précédentes ne fonctionne et que vous travaillez avec une version antérieure. Essayez d’effectuer une mise à niveau vers AutoCAD Plant 3D 2025 ou une version ultérieure.

    1. Installez les dernières mises à jour d’AutoCAD2025 et d’AutoCAD Plant 3D2025.

      1. Il est courant de ne mettre à jour qu’AutoCAD Plant 3D, mais les mises à jour d’AutoCAD sont tout aussi importantes.

    2. Les mises à jour peuvent être téléchargées à partir de votre AutodeskAccount.

    3. Une fois qu’AutoCAD Plant 3D2025 est installé avec les dernières mises à jour :

      1. Exécutez la commande APROPOS. Vous devriez voir quelque chose comme ceci, la version 2025.1 ou plus récente :

AutoCAD Plant 3D 2025 avec les dernières mises à jour appliquées

 

Produits :

AutoCAD Plant 3D ;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance