Le fichier DXF/DWG ou SVG importé ne contient pas de contours fermés dans Fusion

Autodesk Support

8 novembre 2024


Produits et versions couverts


Problème :

Des utilisateurs ont signalé qu’un fichierDXF/DWG ou SVG créé dans un autre programme ne possède pas de profil fermé après son importation dans Fusion :

  • Il n’est pas possible d’extruder les contours d’esquisse du fichier importé ni de les extruder ou de les appuyer/tirer.
  • Les contours d’esquisse ne sont pas fermés pour les trajectoires d’outils2D.
  • « Les contours d’esquisse du fichier importé ne peuvent pas être sélectionnés pour certaines trajectoires d’outils, telles que Poche2D. » 

Causes :

  • Le fichier DXF/DWG ou SVG d’origine contient des géométries non prises en charge ou des espaces.
  • « Le fichier DXF importé n’est pas fermé, même si l’esquisse semble fermée."" »

Solution :

Réparation des profils dans le programme source et dans Fusion

  • Dans le programme d’origine, remplacez les fonctionnalités non prises en charge par des types de géométrie pris en charge (tels que les polylignes).
  • Exportez le fichier d’origine au formatSVG au lieu d’un fichierDXF. Il se peut que le fichier doive ensuite être mis à l’échelle (consultez l’article Importation d’un fichierSVG avec une échelle incorrecte dans Fusion). 
  • Tracez des lignes dans Fusion à l’aide de lignes, de splines ou de cercles.
  • Connecter des extrémités déconnectées en appliquant une contrainte de coïncidence (le complément gratuit Vérificateur d’esquisse peut vous aider à identifier les espacements).
  • "Pour rechercher les éléments non contraints, consultez l’article suivant : Comment rechercher des éléments d’esquisse sous-contraints dans Fusion
  • Éliminez les zones où le profil risque d’être doublé ou de se croiser.
  • « À partir de l’onglet Surface, utilisez l’option Corriger pour créer une surface et extruder/épaissir la nouvelle surface."" »
  • Coupez la région acérée et rattachez les deux contours.
  • Recherchez les points blancs désignant le segment d’esquisse déconnecté après l’importation du fichierDXF. « Pour résoudre ce problème, procédez comme suit : »
  1. Ouvrez le fichier DXF.
  2. Vérifiez la présence d’un point blanc dans l’esquisse, car le segment d’esquisse connecté est noir.                                        
Vérifier la présence d’un point blanc dans l’esquisse
  1. Supprimez la ligne droite reliant le point blanc.
  2. Recréez la ligne reliant les deux extrémités.

Ouvrez le fichier DXF ou SVG dans un programme d’édition de graphiques vectoriels pour réparer les profils.

  1. Choisissez un programme tel que
    • Inkscape
    • Concepteur d’affinités
    • Adobe Illustrator
  2. Ouvrez l’esquisse DXF ou SVG dans le programme choisi.
  3. Réparez toute géométrie manifestement incorrecte.
  4. Utilisez l’outil Remplissage de peinture pour remplir les zones de l’esquisse. Cela permet de créer un profil solide qui représente la couleur de remplissage. Une fois importé dans Fusion, Fusion ne verra que le contour de remplissage de couleur et non la couleur.
  5. Exportez l’esquisse à partir de l’éditeur de graphiques vectoriels au format DXF ou SVG.
  6. Importez-le dans Fusion.
  7. Vérifiez que la géométrie respecte la tolérance et effectuez les ajustements nécessaires. 
 
 
 

Produits :

Fusion ;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance