Erreur "Impossible d'initialiser le complément, car une application existe déjà avec ce noeud AddInId." à l'ouverture de Revit

Autodesk Support

11 juillet 2024


Produits et versions couverts


Problème :

Lors du lancement de Revit, le message d'erreur suivant s'affiche :  

Outils externes - ID de complément dupliqué

Impossible d'initialiser le complément "Nom du complément", car une application existe déjà avec ce noeud AddInId.
Le noeud Addinid est un identificateur unique global (GUID) utilisé pour identifier l'application complémentaire. Revit possède déjà une application enregistrée avec le GUID indiqué.

  • Remarque : le complément exact répertorié dans l'erreur varie. Reportez-vous aux exemples illustrés ci-dessous.
Outil externe-ID de complément dupliqué
Outils externes-IDDépongeDupliquée
 
 

Causes :

Deux dossiers tentent d'enregistrer le même complément.

Solution :

Pour résoudre ce problème, effectuez une ou plusieurs des opérations suivantes :

  • Désinstallez le complément.
  • Si le complément est fourni avec Revit (et non dans le cadre d'un processus d'installation séparé), réparez l'installation ou effectuez une désinstallation propre de l'ensemble du programme : 
  • Supprimez les fichiers temporaires du dossier temporaire.
  • Recherchez dans le répertoire suivant les entrées en double et supprimez les fichiers de complément du programme qui contient l'erreur :
    • C:\ProgramData\Autodesk\Revit\Addins\[Version].
  • Supprimez les fichiers de complément du programme et l'erreur se produit à l'emplacement suivant :
    • C:\%userprofile%\AppData\Roaming\Autodesk\Revit\Addins\[Version].
    • C:\ProgramData\Autodesk\ApplicationPlugins.
      • Remarque : cet emplacement peut être utilisé pour les compléments qui s'étendent sur plusieurs produits ou versions.

Produits :

Revit ;


Ces informations vous ont-elles été utiles ?


Besoin d’aide ? Demandez à l’Assistant Autodesk.

L’Assistant peut vous aider à trouver des réponses ou à contacter un agent.


Quel est votre niveau d’assistance actuel ?

Chaque plan d’abonnement inclut différentes catégories d’assistance. Découvrez le niveau d’assistance qui correspond à votre plan.

Voir les niveaux d’assistance