Autodesk 2019 products freeze when using borrowed licenses while not connected to license server

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

Autodesk 2019 products may lag and freeze intermittently when using a borrowed license. This problem happens if the workstation is connected to the Internet, but not to a license server.

Causes:

When a license is borrowed, Autodesk 2019 software sends a heartbeat signal to the license server.

If the workstation can connect to the license server, the issue does not occur. Also, if there is no internet connection, the issue does not occur.

If the workstation can connect to Internet, the software sends a heartbeat signal to the license server. If the license server is on a different network, the server cannot be reached, and the software hangs for around 10-20 seconds with every heartbeat signal sent.

Solution:

Download and install the latest Autodesk License Service Hotfix:

VersionPlatformDownload link
2019Windows (32-bit)Autodesk_License_Service_(x86)_7.1.7_Hotfix_1.msp
Windows (64-bit)Autodesk_License_Service_(x64)_7.1.7_Hotfix_1.msp
macOSAutodesk_License_Service_7.1.7_Hotfix_1.pkg
LinuxAutodesk_License_Service_7.1.7_Hotfix_1.tar.gz

Installation Instructions:

Windows
  • Close all Autodesk applications.
  • Download the msp hotfix file 32-bit or 64-bit.
  • Run the .msp file to start the installation.

macOS
Linux
  • Close all Autodesk applications.
  • Download the file Autodesk_License_Service_7.1.7_Hotfix_1.tar.gz.
  • Decompress the downloaded file. In the terminal, navigate to the folder containing the .tar.gz file and run the command: tar -zxvf Autodesk_License_Service_7.1.7_Hotfix_1.tar.gz
  • Run the ./Autodesk_License_7.1.7_Hotfix_1.sh file with administrator privileges to install the hotfix.
Note: If the solutions above do not resolve the issue reinstall your Autodesk product.

Products:

3ds Max; AutoCAD Products; Inventor Products; Maya; Navisworks Products; Revit Product Family; Showcase; CFD; Moldflow Insight; SketchBook Products; Vehicle Tracking; FeatureCAM Products; PowerMill; PowerShape;

Versions:

2019;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support