"Caricamento del file di personalizzazione non riuscito. File non trovato: [nomefile]" all'avvio dei prodotti AutoCAD

Autodesk Support

11 febbraio 2025


Prodotti e versioni incluse


Problema:

Quando si avvia un prodotto AutoCAD o DWG TrueView, viene visualizzato il seguente messaggio:

Caricamento del file di personalizzazione non riuscito. File non trovato.
C:\Utenti\nomeutente\AppData\Roaming\Autodesk\AutoCAD 20xx\Rxx\lingua\Support\acad"

Caricamento del file di personalizzazione non riuscito. File non trovato

o

Caricamento del file di personalizzazione non riuscito. File non trovato: acad

Caricamento del file di personalizzazione non riuscito. File non trovato: acad

Nota: il titolo della finestra del messaggio e il percorso del file variano in base al prodotto specifico.

Inoltre:

  • Il prodotto AutoCAD potrebbe avviarsi comunque, ma elementi dell'interfaccia come la barra multifunzione, le tavolozze degli strumenti e le aree di lavoro potrebbero mancare.
  • Potrebbe essere visualizzato anche il seguente messaggio: "Impossibile aprire il file di personalizzazione...".
 
 

Cause:

  • In AutoCAD è stato installato un file ARG di un set di strumenti di AutoCAD.
  • File delle impostazioni di AutoCAD danneggiati o mancanti.
  • Le impostazioni vengono salvate in un percorso con restrizioni. 
  • Avvio del software da un account utente con restrizioni.
  • Profili di roaming di Windows. 
  • Impostazione errata nel file acaddoc.lsp-.

Soluzione:

Effettuare una o più operazioni tra quelle indicate di seguito:

Per verificare se il file ARG installato proviene da un set di strumenti di AutoCAD

Non è possibile importare un file ARG da un set di strumenti di AutoCAD (ad esempio, AutoCAD Architecture o AutoCAD Mechanical), in AutoCAD o AutoCAD LT.
Per verificare se un file ARG proviene da un set di strumenti di AutoCAD, eseguire le operazioni seguenti:

  1. Aprire il file ARG in un editor di testo, ad esempio Blocco note.
  2. Individuare le informazioni relative a HKEY.

In questo modo verrà visualizzata la versione, ad esempio R24.3 per la versione 2024, e il tipo di file ARG. Ad esempio, in un file ARG di AutoCAD Architecture verranno visualizzate le seguenti informazioni:

"ProfileAKA"="Architectural Desktop - Imperial".
"UserName"="".
"NFWState"=dword:00000001.
"WorkspaceNameAtProfileSave"="Architecture".


File di configurazione mancanti o danneggiati

Provare ad eseguire una delle operazioni seguenti:


Limitazioni delle autorizzazioni

Eseguire i passaggi seguenti:

  1. Rimuovere le limitazioni delle autorizzazioni dall'utente Windows corrente.
  2. Riavviare il sistema.
  3. Eseguire di nuovo AutoCAD.

Nota: in Windows 10, gli utenti con limitazioni non possono modificare i file, le cartelle e le voci del Registro di sistema esterne al proprio profilo utente. Per supportare gli account utente con limitazioni, tutti i file e le impostazioni del Registro di sistema personalizzabili di AutoCAD vengono memorizzati nel profilo utente. Gli utenti devono disporre delle autorizzazioni di controllo completo per tutti i file e le cartelle incluse nella directory C:\Utenti\nomeutente. Gli utenti devono inoltre disporre delle autorizzazioni di controllo completo per tutte le chiavi e i valori della chiave del Registro di sistema HKEY_CURRENT_USER. Le restrizioni che limitano l'accesso dell'utente a questi percorsi possono causare errori nel programma di installazione secondario di AutoCAD o all'interno dell'applicazione stessa. Vedere Impossibile eseguire AutoCAD come utente con limitazioni.


Informativa errata nel file acaddoc.lsp-

  1. In Esplora file, accedere a \Support\en-US.
  2. Aprire il file acaddoc.lsp con un editor.
  3. Cercare il comando "CARICAIUPERS" in questo file ed eliminare o commentare la riga.
    • È possibile creare un file di testo e rinominarlo acad.lsp in C:\Utenti\\AppData\Roaming\Autodesk\AutoCAD 2024\R24.3\enu\Support. Incollare qui l'istruzione CARICAIUPERS dal file acad.lsp. Il file acad.lsp verrà eseguito per default una sola volta all'avvio del prodotto AutoCAD (Opzioni - Scheda "Sistema" - Pulsante "Opzioni di protezione").
  4. Salvare il file


Ambiente Citrix

  • Gli account utente Citrix devono disporre dell'accesso ai file di installazione di AutoCAD affinché AutoCAD possa inizializzarsi correttamente quando viene eseguito per la prima volta.
  • Utilizzare lo script PostInstall di Citrix per compilare le cartelle e le chiavi del Registro di sistema di AutoCAD necessarie per l'utente. Vedere Script post-installazione di AutoCAD Map 3D Citrix.
Nota: questi script automatizzano le modifiche del Registro di sistema e del profilo utente dopo l'installazione di AutoCAD. Anche se sono stati scritti per AutoCAD Map 3D o versioni precedenti di Windows Server, sono validi per le versioni più recenti di Windows/AutoCAD e per tutti i prodotti basati su AutoCAD, ad esempio Plant 3D e Architecture.

Prodotti:

AutoCAD Products; Advance Steel; DWG TrueView; Fabrication CADmep;


Queste informazioni sono state utili?


Hai bisogno di aiuto? Chiedi all'Assistente Autodesk!

Per trovare le risposte alle tue domande, chiedi all'Assistente oppure contatta un agente.


Di quale livello di supporto disponi?

I vari piani di abbonamento forniscono diverse categorie di supporto. Scopri il livello di supporto per il tuo piano.

Visualizza i livelli di supporto