"La rappresentazione della vista disegno corrente è bloccata. "Le modifiche apportate non verranno salvate." viene visualizzato durante il salvataggio di un file di Inventor."

Autodesk Support

12 dicembre 2024


Prodotti e versioni incluse


Problema:

Quando si tenta di salvare un file di parti o assiemi di Inventor modificato, viene visualizzato il seguente messaggio:

La rappresentazione della vista disegno corrente è bloccata e le modifiche apportate alla rappresentazione non verranno salvate. Se si desidera mantenere tali modifiche, fare clic su Annulla e creare una nuova rappresentazione della vista disegno o sbloccare quella corrente. Per continuare e ignorare le modifiche apportate alla rappresentazione bloccata, fare clic su OK.


Messaggio di errore visualizzato in Inventor  
Esempio di messaggio di errore in Inventor 

Viene inoltre visualizzata un'icona a forma di lucchetto davanti al nome della parte che si sta tentando di revisionare:

Messaggio d'errore per la vista rappresentazione 

Cause:

Quando una rappresentazione della vista disegno è bloccata, non è possibile salvare le modifiche ai seguenti elementi della vista disegno in essa contenuti:

Elementi dell'assieme:

  • Visibilità dei componenti (visibili o non visibili)
  • Trasparenza componente
  • Visibilità della lavorazione di schizzo se lo stato di visibilità è controllato dal comando Visibilità oggetto. (Non acquisisce lo stato di visibilità se lo schizzo è attivato o disattivato nel browser)
  • Visibilità delle geometrie di lavoro (visibili o non visibili)
  • Stato di selezione del componente (abilitato o non abilitato)
  • Caratteristiche di aspetto e stile applicate nell'assieme
  • Livello di ingrandimento
  • Angolo di visualizzazione
  • Rappresentazioni vista parte
Elementi della parte:
  • Aspetto del corpo
  • Visibilità dello schizzo
  • Visibilità del blocco di schizzo
  • Visibilità della geometria di lavoro
  • Visibilità dell'UCS
  • Stato di espansione del browser
  • Livello di ingrandimento
  • Angolo di visualizzazione

Soluzione:

Mentre si lavora nell'ambiente di assiemi:

La soluzione dipende dal fatto che si desideri mantenere o meno le sostituzioni apportate ad uno o più degli elementi dell'assieme o della parte sopra elencati.

  • Se non si desidera mantenere le sostituzioni effettuate, è sufficiente fare clic su OK nella finestra di dialogo del messaggio. Le sostituzioni non verranno memorizzate nella vista attiva, ma eventuali modifiche alla geometria verranno salvate.
Nota: una casella di controllo selezionata indica la vista di disegno attiva, come per "RedCubes" nell'esempio seguente.
  • Se si desidera mantenere le sostituzioni effettuate, fare clic su Annulla nella finestra di dialogo del messaggio. È necessario sbloccare la vista di disegno o crearne una nuova in cui salvare le sostituzioni:
Per sbloccare la vista Per aggiungere una nuova vista 
 

Nota: La vista "principale" è sempre bloccata e non può essere sbloccata o eliminata. Pertanto, gli elementi nella vista principale non possono essere sostituiti. Se la vista principale è attiva, è necessario creare una nuova vista di disegno o attivare una vista di disegno sbloccata in cui salvare le modifiche:

Per aggiungere una nuova vista Attivare la vista 


"Per ulteriori informazioni sulle viste di progettazione, guardare il video di Autodesk Virtual Academy, Design Views in Inventor."""
 

Quando si lavora nell'ambiente di parti:

  • Nell'ambiente del modello di parti, il messaggio di richiesta viene visualizzato perché la vista in sezione grafica è considerata una sostituzione della vista di disegno. La vista di disegno primaria (principale) è sempre bloccata e la sostituzione non può essere salvata. 
  • Per risolvere questo problema, è possibile modificare il modello in modo che la visualizzazione bloccata non sia quella predefinita. Lavorare invece nelle viste che possono essere sbloccate per evitare che si verifichi questo problema.

 

 

Prodotti:

Prodotti Inventor


Queste informazioni sono state utili?


Hai bisogno di aiuto? Chiedi all'Assistente Autodesk!

Per trovare le risposte alle tue domande, chiedi all'Assistente oppure contatta un agente.


Di quale livello di supporto disponi?

I vari piani di abbonamento forniscono diverse categorie di supporto. Scopri il livello di supporto per il tuo piano.

Visualizza i livelli di supporto