"Dopo l'esecuzione del messaggio "Preparazione per l'installazione..."" non accade più quando si installa un prodotto Autodesk 2021 o versioni successive

Autodesk Support

14 febbraio 2025


Prodotti e versioni incluse


Problema:

"Quando si tenta di installare Autodesk 2021 o una versione successiva, viene visualizzato il messaggio "Preparazione dell'installazione..." ma dopo non succede nulla e l'installazione non inizia dopo la chiusura della finestra 

Preparazione per l'installazione in corso...

Preparazione all'installazione
 

Cause:

  • Problemi di autorizzazione

  • Restrizioni di rete

  • Problemi relativi ai certificati

  • Programma di installazione di ODIS danneggiato

Soluzione:

Per risolvere il problema, impostare l'autorizzazione di Windows ed eseguire l'installazione dalla riga di comando attenendosi alle istruzioni.

Impostare le autorizzazioni di Windows

Assicurarsi che le seguenti cartelle dispongano dell'autorizzazione di lettura/scrittura:

  • C:\Programmi

  • C:\Program Files (x86)

  • C:\ProgramData

 

Nella riga di comando, eseguire l'installazione, Setup.exe.

  1. Fare clic sul pulsante Start di Windows.

  2. Digitare cmd per aprire il prompt dei comandi ed eseguirlo come amministratore. 

  3. Digitare quanto segue e premere INVIO. 

    cd C:\Autodesk\AutoCAD_2022_English_Win_64bit_dlm\

Nota. Il percorso può essere diverso. Verificare prima il percorso esatto in C:\Autodesk.

  1. Digitare quanto segue e premere INVIO.

    Setup.exe --noupdate
  2. Dovresti avere qualcosa di simile al prompt dei comandi e l'installazione dovrebbe finalmente avviarsi.

Installazione senza aggiornamenti

Controllare i registri eventi per verificare la presenza di eventuali errori

  1. Vedere: Come ottenere i registri eventi di Windows per la diagnostica e la risoluzione dei problemi

  2. Questo problema può essere correlato a: "Errore 2: il sistema non è in grado di trovare il file specificato." quando si avvia Autodesk Access host del servizio


"Se nel file di Setup.log è presente l'errore "Codice di uscita del sistema 1260":"

2022-09-13T15:51:01.516 [Bootstrap: 12932, single] [Bootstrap ERROR] [BS_Setup::ExecuteCommand ]     => Process failed to launch. System exit code  1260

Seguire la procedura:

  • Disinstallare e reinstallare il componente ODIS prima di installare il software
    1. Passare a C:\Programmi\Autodesk\AdODIS\V1.

    2. Eseguire RemoveODIS.exe come amministratore.

    3. Rimuovere il contenuto della cartella C:\ProgramData\Autodesk\ODIS\.

    4. Scaricare e installare la versione più recente di ODIS.

  • "Cancellare le cartelle "%temp%" e ""%localappdata%\autodesk\ODIS"."
  • "Eseguire il programma di installazione dalla riga di comando di un amministratore (digitare "cmd"""" nella casella di ricerca di Windows e "Esegui come amministratore"") con il comando seguente:"
"C:\Program Files\Autodesk\AdODIS\V1\Installer.exe" --install_mode install --manifest "C:\Autodesk\AutoCAD_LT_2023_English_Win_64bit_dlm\setup.xml" --manifest_xsd "C:\Program Files\Autodesk\AdODIS\V1\SetupRes\manifest.xsd"  --offline_mode --trigger_point local

 

Aggiornamento dei certificati attendibili

Assicurarsi che tutti i certificati attendibili siano installati e aggiornati nel computer seguendo la procedura descritta nell'articolo: Aggiornamento dell'elenco di certificati principali attendibili in Windows

 

Prodotti:

Tutti i prodotti desktop


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