Quando si installano gli aggiornamenti di Inventor viene visualizzato il messaggio di errore "La funzionalità che si sta tentando di utilizzare si trova in una risorsa di rete non disponibile"

Autodesk Support

16 novembre 2023


Prodotti e versioni incluse


Problema:

Quando si tenta di installare gli aggiornamenti di Inventor, viene visualizzato il seguente messaggio:
 
Versione di Autodesk Inventor Professional
L'entità geografica che si sta tentando di utilizzare si trova in una risorsa di rete non disponibile.
Fare clic su OK per riprovare oppure immettere il percorso della cartella contenente il pacchetto di installazione "inventor.msi(InventorLP.msi)" nella casella sottostante.
 
image.png

Ambiente:

  • Windows 10
  • Windows 11

Cause:

Il problema è dovuto al fatto che il pacchetto di installazione originale di Install Media for Inventor è stato rimosso dalla posizione originale sul computer. Durante la reinstallazione, il processo cerca il supporto di installazione ma non lo trova e restituisce il messaggio di errore precedente.

Soluzione:

Utilizzo del supporto di installazione

  1. Scaricare il pacchetto di installazione di Inventor 20xx da Autodesk Account utilizzando l'opzione Download.
  2. Estrarre il programma di installazione in una cartella di scelta. Per default, la posizione di estrazione è: 
  • Versioni 2021 e successive: C:\Autodesk
  • Versioni 2022 e successive: Download\Autodesk
  1. Avviare il processo di reinstallazione.
  2. Quando viene visualizzata la finestra precedente, fare clic su Sfoglia e individuare la cartella in cui si trova il file Inventor.msi, quindi fare clic su OK. Per default, il percorso è C:\Autodesk\Inventor_20xx_English_Win_64bit_dlm\x64\inventor\.
  3. Quando viene visualizzata nuovamente la finestra precedente in cui viene richiesto di inventorLP.msi, fare clic su Sfoglia e individuare la cartella in cui si trova il file iInventorLP.msi, quindi fare clic su OK. Per default, il percorso è C:\Autodesk\Inventor_20xx_English_Win_64bit_dlm\x64\en-us\inventor\.


Modificare la chiave LastUsedSource nel Registro di sistema per modificare il percorso memorizzato in MSI

  1. Scaricare ed estrarre il supporto di installazione di Inventor 2016. Per default, si tratta di C:\Autodesk\Inventor_20xx_English_Win_64bit_dlm. È possibile spostare questa voce in una condivisione di rete a cui possono accedere i computer client.
  2. Aprire il Registro di sistema di Windows (premere WIN+R > digitare regedit > premere INVIO)
  3. Aprire l'hive del Registro di sistema HKEY_CLASSES_ROOT\Installer\Products\195DD4F746021000000017707DF0D34B\SourceList
  4. A destra, individuare la chiave LastUsedSource e fare doppio clic su di essa.
  5. Sostituire il vecchio percorso del supporto di installazione con il nuovo percorso che punta a Inventor.msi. Ad esempio, se il supporto di installazione è stato estratto nel percorso di default, sarà C:\Autodesk\Inventor_20xx_English_Win_64bit_dlm\x64\inventor\
  6. Fare clic su OK per chiudere la chiave
  7. Go to HKEY_CLASSES_ROOT\Installer\Products\195DD4F746021000000017707DF0D34B\SourceList\Net
  8. Fare doppio clic sulla chiave 1 e sostituire il vecchio percorso con quello nuovo.
  9. Go to HKEY_CLASSES_ROOT\Installer\Products\195DD4F746021000013317707DF0D34B\SourceList
  10. A destra, individuare la chiave LastUsedSource e sostituire il percorso con il nuovo che punta a inventorLP.msi. Ad esempio: C:\Autodesk\Inventor_20xx_English_Win_64bit_dlm\x64\en-us\inventor\
  11. Open HKEY_CLASSES_ROOT\Installer\Products\195DD4F746021000013317707DF0D34B\SourceList\Net
  12. Aprire la chiave 1 e sostituire il vecchio percorso con quello nuovo.

Prodotti:

Prodotti Inventor

Versioni:

2024; 2016;


Queste informazioni sono state utili?


Hai bisogno di aiuto? Chiedi all'Assistente Autodesk!

Per trovare le risposte alle tue domande, chiedi all'Assistente oppure contatta un agente.


Di quale livello di supporto disponi?

I vari piani di abbonamento forniscono diverse categorie di supporto. Scopri il livello di supporto per il tuo piano.

Visualizza i livelli di supporto