Project will not upgrade in Revit

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

Prior version Revit model will not successfully open in current version.

Causes:

The upgrade process can require that a large number of changes are made to the Revit model.
 
As changes are made, if the model is not in a good state, then these changes may fail, or lead to unexpected behavior.

Solution:

Guided solution

See the following guide for troubleshooting this behavior: Troubleshooting issues with upgrading Revit models

--------------------------------------------------
Alternatively, see the following possible issues related to this error below:

Close Other Software

  1. Close down all programs except Revit
  2. Open the target Revit release and initiate the upgrading process
  3. Give it time to run through everything - it can sometimes halt between certain percentages but will continue again afterwards
Note: If the process halts it might sometimes freeze the screen, giving an impression that the process has stopped, but in reality it will in most cases keep running and unfreeze when it's done.  

Cleanup Model

Open in Prior Version

Go through the following steps in the version of Revit that the file was last saved in (if possible):

 

  1. Ensure Revit is updated to the latest build.
  2. Open the file with the Audit option selected (and Detach from Central if available).
  3. Use the Purge Unused command to purge unneeded families from the model. (Purge 3 times to  purge dependent items)
  4. In the Manage Links dialog box, unload all RVT links (this will prevent Revit from trying to temporarily upgrade each of the linked files).
  5. Clear as many warnings as possible.
  6. Close all views but one (preferably a drafting view, not a 3D view)
  7. Save the file to a new location (especially if detaching from central) or re-save it with the Compact File check box selected (in the File Save Options).

Open in Newer Version

  1. Ensure Revit is updated to the latest build.
  2. Open the model by clicking File > Open > Project and navigating to the model. Select the model, put a check in the Audit box, and click OK.
  3. Save the model with a new filename immediately after upgrading the model..

Continuing Errors

If an error dialog prevents the upgrade process, expand the error, and note down element IDs of the affected elements.

 

  1. Remove these elements in the prior version, and then see if the project will upgrade. (Use Manage > Inquiry > Select by ID to find these elements)
  2. Also check the journal file recorded when upgrading to see if there are element IDs recorded.
  3. Remove these elements and see if the model will upgrade.  (Use Manage > Inquiry > Select by ID to find these elements)
--------------------------------------------------

Products:

Revit Product Family;

Versions:

all;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support