Revit slow performance

Autodesk Support

Jul 30, 2024


Products and versions covered


Issue:

Slow performance when working in Revit.

Causes:

Working in a Revit model involves interacting with many systems, and if any one (or more) of those systems have slow performance, the entire experience in Revit can be slowed down.

At a high level, there are the following systems:
  • The Revit software.
  • Supporting software (for example, Microsoft .NET Framework, Visual C++ Redistributable).
  • Third party software and services (that are running at the same time as Revit taking resources away from the system and potentially directly interfering with the program).
  • The storage media (slow performance reading or writing to the storage media will slow down operations that do this).
  • The operating system (OS updates can influence Revit performance).
  • The system hardware (including CPU, Graphics Card, RAM...).
Important points to keep in mind when looking at performance issues:
  • If the performance recently changed, what (if any) of the items above were changed?
  • What are you comparing the performance against? (For example, if a new system appears to be slower than an older system, review the journals of both systems when going through similar steps to look for differences as well as comparing the specifications between the systems).

Solution:

Initial items to check

  1. Check that Revit is updated.
  2. For files hosted on a network or cloud location, save a local copy and retest (to identify if the issue is with the model, or the remote resource).
  3. If there are linked models, test unloading the links, to identify if the links are related to the slow performance.
  4. Disable add-ons to identify if they are related to the slow performance: How to disable add-ons for Revit

If the steps above do not lead to a solution, see the following categories for further troubleshooting.

Model Specific performance

See the following article for guidance on model specific performance issues: How to improve, optimize, or troubleshoot model performance in Revit

Cloud Models

Worksharing (not cloud based)

Other

See the following link for other articles on this topic: Performance and Graphics

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support