図面を AutoCAD Map 3D 2018 および 2019 から Autodesk Infrastructure Map Server 2017 にパブリッシュできますか?

Autodesk Support

2023年10月8日


対象となる製品とバージョン


問題:

Infrastructure Map Server 2017 (AIMS)を使用して、AutoCAD Map 3D 2018および2019からデータをパブリッシュする場合に適しています。

原因:

Autodesk Infrastructure Map Serverの最新バージョンは2017ですが、AutoCAD Map 3D 2018と2019を使用しています。

解決策:

回答は、図面に含まれているFDO接続によって異なります。
図面内の次のFDO接続は、Map 3D 2018および2019からInfrastructure Map Server 2017に正常にパブリッシュでき、余分な作業を行わずにWebレイアウトに正しく表示されます。
FDO SDF
FDO SHP
FDO SQLite
FDO MySQL
FDO Oracle
FDO PostgreSQL
FDO SQL Server
FDO WFS
FDO ArcSDE
 
FDO ODBCを使用した図面、FDO Raster、FDO WMS接続
これらの3つの接続はMap 3D 2018でパブリッシュできますが、Infrastructure Map Server 2017では動作しません。これらの3つのFDO接続をInfrastructure Map Server 2017で機能させるには、アタッチされた修正プログラムをダウンロードし、次のインストール手順に従います。
  1. この修正プログラムを適用する前に、関連ファイルをすべてバックアップしてください。
  2. C:\Program Files\Autodesk\Autodesk Infrastructure Map Server 2017\Bin\FDO and replace all the related files with the files in the hotfix packageフォルダに移動します。
  3. Autodesk Infrastructure Studioをインストールしている場合は、C:\Program Files\Autodesk\Autodesk Infrastructure Studio 2017\FDO folder and replace all the related files with the files in the hotfix packageにアクセスする必要もあります。
  4. Windowsの[サービス]パネルで、Infrastructure Map Server 2017サービスを再起動します。
AutoCADオブジェクトを含む図面  
Map 3D 2018および2019で導入されたAutoCAD 2018形式の図面は、Infrastructure Map Server 2017では認識できません。したがって、オブジェクトをInfrastructure Map Server 2017で正しく動作させるには、図面をAutoCAD 2013図面形式で保存します。

 ユーザが追加したイメージ

エンタープライズインダストリモデル2018:
Map 3D 2018を使用しているため、データベースがOracleまたはSQL Serverであっても、既存のMAPSYSが2018バージョンにアップグレードされている可能性があります。変更’する必要はありません。Infrastructure Map Server 2017のアプリケーション拡張機能は、アップグレードされたMAPSYSで引き続き動作します。  また、Map 3D 2018で作成されたインダストリモデルをInfrastructure Map Server 2017にパブリッシュすることができ、アプリケーション拡張機能の対応するWeb機能も正常に動作します。

エンタープライズインダストリモデル2019:
Map 2019では、インダストリモデルの新しいMAPSYSとデータ構造が導入されました。プロジェクトは引き続きAIMS 2017にパブリッシュすることができ、アプリケーション拡張機能内の対応するWeb関数も正常に動作します。

 

製品:

AutoCAD Map 3D; Infrastructure Map Server;

バージョン:

2017; 2018;


この情報は役に立ちましたか?


サポートが必要な場合は、Autodesk Assistant にお問い合わせください!

Assistant が回答を見つけたり、担当者に連絡するお手伝いをします。


オートデスクではどのようなサポートが提供されますか?

ご利用可能なサポートの種類は、サブスクリプションのプランによって異なります。現在のプランでご利用可能なサポート レベルをご確認ください。

サポート レベルを確認