Palettes do not display or missing in AutoCAD Products

Autodesk Support

Feb 7, 2025


Products and versions covered


Issue:

When working with palettes in AutoCAD products, one of the following happens:
  • When trying to open a palette, nothing happens or an "Unknown command" message appears on the command line.
  • When moving a palette to another screen, it flickers or disappears.
  • Some palettes supposed to be active but they do not display.
Palettes include but are not limited to:
  • Tool palettes (TOOLPALETTES).
  • External references manager (XREF, IMAGE).
  • Layer properties manager (LAYER).
  • Object properties (PROPERTIES).
  • Blocks (BLOCKSPALETTE, INSERT)
  • Design Center (ADC or DC).
  • OCR (Text Recognition for Raster Design Tool)
  • Command line window.

Causes:

  • Clean Screen mode is enabled.
  • The tool needed is not selected in the customized palette.
  • The palette is positioned to display an X,Y location which is off the current screen.
  • The palette is off-screen and the interface is locked from getting changed (LOCKUI).
  • Using multiple screens (dual monitor) and dragging the palette to a location in between.
  • AutoCAD product crashed beforehand.
 

Solution:

Toggle Clean Screen Mode On/Off

Clean Screen mode can be toggled on/off by pressing Ctrl+0 on the keyboard.

Verify that the Palette is Enabled

  1. Enter CUI on the command line.
  2. Select the current workspace on the left.
  3. Click "Customize Workspace" on the right.
  4. Expand "Palettes" and select the affected palette.
  5. In the Properties of the selected palette, check if the entry for Appearance -> Show is set to Yes.

Palette Display Position (X, Y) is Off-Screen

  • Edit the palette in the CUI editor. Using the Properties palette as an example, follow these steps: Do one or more of the following: 
  1. Enter CUI on the command line.
  2. Select the current workspace on the left.
  3. Click "Customize Workspace" on the right.
  4. Expand "Palettes" and select "Properties".
  5. Change the appearance settings to:
    • Show: Do not change
    • Orientation: Floating
    • Allow Docking: No
    • Auto Hide: Off
    • Size: Height = 0, Width = 0
  6. Click "Done"  at the top and then click "OK".

    Note: Toggling the Orientation and Docking settings above 'Docked' and 'Yes,' respectively, may help to get the palette to show.

  • For the Tools palette, edit the AWS file to change its coordinate (position):
  1. Exit AutoCAD.
  2. Browse to the profile.aws file. The default location is in the following folder: 
    C:\Users\<user>\AppData\Roaming\Autodesk\AutoCAD 20xx\Rxx.x\enu\Support\Profiles\Unnamed Profile\<profile>.aws
  3. Open the .aws file in Notepad.
  4. Locate the first instance of the element FloatInfo Left and change the values as follows:
    <FloatInfo Left="100" Top="150" Width="175" Height="750"/>
  5. Save and close the .aws file and restart AutoCAD.
  • To reset all palettes to their default coordinate locations:
  1. Exit AutoCAD.
  2. Browse to the profile.aws file. The default location is in the following folder: 
    C:\Users\<user>\AppData\Roaming\Autodesk\AutoCAD 20xx\Rxx.x\enu\Support\Profiles\Unnamed Profile\
  3. Rename "Profile.aws" to "Profile.old" 
  4. Restart AutoCAD.
If necessary, one can revert to the original "profile.aws" if the changes are not as expected.

Important:

If the LOCKUI system variable is not set to 0 (zero) while the palette is off-screen, you will need to turn off the LOCKUI before you can grab the palette from the edge of the monitor. 

Check if Palette is Docked with Zero-width

After confirming that the palette is docked and shown, it is possible that the palette has zero-width. In general the palettes are either docked on the left or on the ride side of AutoCAD. 

  1. Move the cursor close to the edge of AutoCAD and check if the cursor icon changes to palette resizing
AutoCAD - Resizing of docked zero-width palette.
  1. Click and drag the resize cursor to change the size of the affected palette.

Now the palette can be repositioned again.

Toggle Workspace and working Profile

  • Change your AutoCAD profile so that you have at least two Workspaces - duplicate your workspace if you only have one of them. Then switch between the two Workspaces to bring the palettes back on screen.  
  • Toggle AutoCAD profiles. For example, if the issue is experienced in AutoCAD Architecture (US Imperial) profile, switch to AutoCAD Architecture (US Metric) and then switch back to AutoCAD Architecture (US Imperial). 

Additional Troubleshooting 

  • Check using an alternate method of displaying the palette. Many palettes can be enacted by a button on the ribbon, a menu item, a keyboard shortcut, or a command on the command line. For example, the Properties palette can be displayed by pressing Ctrl+1 or by typing in PROPERTIES on the command line (along with PROPERTIESCLOSE to close it).
  • Test maximizing, minimizing, restoring, and resizing the AutoCAD program window. This may show part of the palette that can be clicked and dragged into full view.
  • Reduce or increase the resolution of the screen (you can do this by right-clicking the desktop and choosing "Screen Resolution").
  • Set the scale and resolution of the different monitors to the same value in the display settings of Windows.
  • Reset AutoCAD to defaults. See: How to reset AutoCAD to defaults.
  • Reinstall AutoCAD. See: How to repair or reinstall an AutoCAD installation.
Note: Disable Snap windows option from the operating system to prevent it from potentially repositioning palettes when moved between screens. Type 'multitasking settings' into the Start menu and turn off Snap windows.
 
 
 
 

Products:

AutoCAD Products; Fabrication CADmep;


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