3ds Max 2017에서 네트워크 렌더를 통해 작업을 보낼 때 Mental Ray 구성요소에 대한 "DLL 누락" 오류 발생

Autodesk Support

2023년 10월 8일


다루는 제품 및 버전


문제:

네트워크 렌더(Backburner, Deadline 등)를 통해 작업을 보내는 경우 여러 Mental Ray 플러그인을 로드할 수 없으며 3ds Max에서 누락된 dll 오류가 발생하고 렌더 작업이 실패합니다.

오류에는 다음 dll이 표시됩니다.

dll 누락: mrmaterialattribs.gup - mental ray: 재질 사용자 정의 속성
dll 누락: mrmaterialattribs.gup - mental ray: 변위 사용자 정의 속성
dll 누락: mrmaterialattribs.gup - mental ray: 간접 조명 사용자 정의 속성
dll 누락: mrmaterialattribs.gup - mental ray: 라이트 셰이더 사용자 정의 속성


사용자가 추가한 이미지

원인:

Plugin.UserSettings.ini 파일이 누락되었거나 초기 설치의 *.ini(INI) 파일 내에 디렉토리 경로가 누락되어 있습니다. 3ds Max 2017에서 Plugin.UserSettings.ini가 누락되었거나 불완전할 때 Backburner 또는 Deadline과 함께 Mental Ray 플러그인을 로드할 수 없습니다. 이로 인해 네트워크 렌더 작업이 실패합니다.

C:\Users\\AppData\Local\Autodesk\3dsMax\2017 - 64bit\ENU에 있는 Plugin.UserSettings.ini 파일​. (참고: 이러한 폴더가 표시되지 않으면 이 Microsoft 도움말 링크에 설명된 대로 "숨김 파일/폴더 표시"를 설정하십시오.)

Plugin.UserSettings.ini 파일에는 다음 경로가 포함되어 있습니다.

[Directories]
Additional MAX plug-ins=C:\Program Files\Autodesk\3ds Max 2017\PlugIns
Additional MAX plug-ins NVIDIA=C:\Program Files\Autodesk\3ds Max 2017\PlugIns\NVIDIA\Plugins\
[Help]

 

해결 방법:

오류를 해결하려면 다음을 수행하십시오.
  1. 이 문서의 지침에 따라 최신 버전의 3ds Max 2017용 mental ray를 다운로드하여 설치했는지 확인하십시오.
  2. Plugin.UserSettings.ini가 있는 경우 메모장에서 파일을 열고 [Directories] 아래에 다음 행을 추가합니다.
    • Additional MAX plug-ins=C:\Program Files\Autodesk\3ds Max 2017\PlugIns
    • Additional MAX plug-ins NVIDIA=C:\Program Files\Autodesk\3ds Max 2017\PlugIns\NVIDIA\Plugins\
  3. Plugin.UserSettings.ini가 존재하지 않는 경우 첨부된 INI 파일을 다운로드하여 다음 폴더에 추가합니다.
    • C:\Users\\AppData\Local\Autodesk\3dsMax\2017 - 64bit\ENU 
이전에 실패한 작업이 이제 렌더링됩니다.

참고: 일부 브라우저는 첨부된 Plugin.UserSettings.ini 파일을 다운로드하고 이름을 바꿔 압축된 .zip 파일로 나타낼 수 있습니다. 이 파일을 두 번 클릭하여 .zip으로 열면 파일이 손상되었거나 .zip 파일이 아니라는 오류가 발생합니다.

이 경우 파일 확장자를 .zip에서 .ini로 변경한 다음 위의 2단계를 수행합니다.

첨부 파일:

Plugin.txt;

제품:

3ds Max;

버전:

2017;


이 정보가 도움이 되셨습니까?


도움이 필요하신가요? Autodesk Assistant에게 물어보세요!

Assistant가 답변을 찾아내거나 상담사에게 연락하는 것을 도와드릴 것입니다.


어떤 지원을 받을 수 있는지 확인하세요.

서브스크립션 플랜에 따라 제공되는 지원 유형이 달라집니다. 보유하신 플랜에 대해 제공되는 지원 수준을 확인하십시오.

지원 수준 보기