How to perform a clean uninstall of Autodesk Desktop Connector

Autodesk Support

Dec 6, 2024


Products and versions covered


Issue:

How to perform a clean uninstallation and reinstallation of Autodesk Desktop Connector.

Causes:

Common reasons to cleanly reinstall Desktop Connector include:
  • The current installation of Desktop Connector is corrupt, resulting in poor performance.
  • A different version of Desktop Connector is desired for troubleshooting or other reasons.

Solution:

Check the following steps to perform a clean uninstall of Desktop Connector.

Important: For troubleshooting purposes, only uninstall Desktop Connector as a last resort. Do not uninstall the application if this step is not needed.

Notes:

  • For a simple upgrade of Desktop Connector from an already installed version 16.x, do not uninstall the product. Instead, exit Desktop Connector and install the new version directly without an uninstall. See: Update Desktop Connector.
  • Consider alternative troubleshooting practices that can be reviewed in the See Also section before uninstalling Desktop Connector.
  • Administrative permissions may be required to uninstall and reinstall. Refer to: What permissions are required for Autodesk software installation.  


To perform a clean uninstall:

  1. Close all Autodesk software (such as AutoCAD, Civil 3D, Revit, etc.).

  2. In the Taskbar > System Tray, right-click Desktop Connector > click Exit.

  3. Go to Control Panel\All Control Panel Items\Programs and Features and Uninstall the application.

  4. Delete the following folders (to quickly navigate to your user profile folder type %userprofile% in file explorer address bar):​​​

  • C:\Users\<USERNAME>\AppData\Local\Autodesk\Desktop Connector.
  • C:\Users\<USERNAME>\AppData\Local\Autodesk\Web Services\DesktopConnector.
  • C:\Program Files\Autodesk\Desktop Connector.
  • C:\ProgramData\Autodesk\Desktop Connector.
  1. Delete the local Desktop Connector workspace, the default workspace locations are:

    • For Desktop Connector v16.x, delete:

      • C:\Users\<USERNAME>\DC.

  • For Desktop Connector v15.x, delete:
    • C:\Users\<USERNAME>\ACCDocs.
    • C:\Users\<USERNAME>\Fusion.
    • C:\Users\<USERNAME>\ADrive.

Note: delete all workspaces when migrating from DC15.x to 16.x.

  1. Open the Windows Registry Editor (REGEDIT).
  2. Delete the following registry keys:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Desktop Connector.
    • HKEY_CURRENT_USER\SOFTWARE\Autodesk\Autodesk Desktop Connector.
  3. Restart the computer before reinstalling the application.
  4. Reinstall the Desktop Connector. The download link can be found on Desktop Connector Release Notes.


Note:
For Desktop Connector 16.x, if Autodesk Docs is not removed from Windows File Explorer, delete the following registry keys:

  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\... (find and delete the key indicating Desktop Connector).
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\SyncRootManager\DesktopConnector...

Warning:
Use the Microsoft® Registry Editor only at your own risk and only after backing up the registry as well as the  system.dat and  user.dat files as outlined for your operating system in the Microsoft Knowledge Base and in the related solution,  Back up system registry. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.

Products:

Desktop Connector;


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