"An operating system restart is pending" installing Autodesk products

Autodesk Support

Nov 18, 2024


Products and versions covered


Issue:

When installing Autodesk products, the following message is shown and the installation doesn't go through. 

An operating system restart is pending

Please restart your computer to install [product].

An operating system restart is pending

 
 

Causes:

  • Corrupted Windows Registry key.

  • Corrupted Microsoft Visual C++ 2015-2022 Redistributable (x64) 14.34.31931.

  • Windows Update is outstanding.

Solution:

Update Windows and reboot

  1. Click Windows Start.

  2. Go to Settings  > Update & Security.

  3. Click, Windows Update and select 'Check for updates'.

  4. Reboot the PC.

  5. Start Autodesk Product Installation.

 

Delete the RebootRequired subkey in the Windows Registry

  1. Open the Windows Registry (as Admin) by typing Regedit in the Windows search.

  2. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update.

  3. Delete the RebootRequired subkey.

  4. Attempt to install the product again.

 

Uninstall the Microsoft Visual C++ 2015-2022 Redistributable (x64) 14.34.31931

  1. Go to "Programs and Features" in "Control Panel".

  2. Search for the Microsoft Visual C++ 2015-2022 Redistributable (x64) 14.34.31931 and try to uninstall it.

  3. Reboot the system.

  4. Install the software.

Note : If the message "No action was taken as a system reboot is required" shows up while uninstalling the Visual C++, consider the steps after the following screenshot.

System reboot when uninstalling Visual C++
  1. Reboot the system.

  2. Remove the Microsoft Visual C++ 2015-2022 Redistributable (x64) 14.34.31931. See Fix problems that block programs from being installed or removed

  3. Reboot the system.

  4. Install the software.

Create a silent deployment

  1. Go to "Custom Install" in the Autodesk Account.

  2. Create a deployment following the instructions. See Create deployments from Autodesk Account.

  3. Once the deployment is created, in the deployment folder, open the Install <deployment name>.bat file with a text editor.

  4. Remove the rem from the "Install the deployment with basic UI" command and add it to the "Install the deployment silently" command. See How to install Autodesk Products silently.

  5. Save the *.bat file.

  6. Start the *.bat file to start the silent installation. 

Note : The silent installation will not prompt any interface. The installation will finish a couple of minutes after the software icon will show up on the desktop.

    Products:

    All Desktop Products;


    Was this information helpful?


    Need help? Ask the Autodesk Assistant!

    The Assistant can help you find answers or contact an agent.


    What level of support do you have?

    Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

    View levels of support