"An unrecoverable error has occurred…" when opening files in Revit

Autodesk Support

Feb 3, 2025


Products and versions covered


Issue:

  • Users reported that when opening files (sometimes for the second time) in Revit the following error is received:

"An unrecoverable error has occurred.  The program will now be terminated.  All of your data has been recently saved, so there is no need to create recovery files."

Unrecoverable error message
  • The issue may be specific to one member.
  • Opening cloud models may take a long time and result with the mentioned error.
  • The Revit journal shows lines like the following preceding the error:
Exception occurred
ExceptionCode=0xe0434352 ExceptionFlags=0x00000001…
 

Causes:

The possible causes:
  • Damaged SQL component.
  • Add-ons loaded into Revit.

Solution:

Troubleshooting

See the following troubleshooting guide on this error:

Unrecoverable CSP


Disable Revit add-ons

See the instructions in the following article for information on how to Check if add-ons are causing unexpected behavior in Revit.
 

Install latest updates

Make sure that the latest Revit hotfix is installed. For updates check Autodesk Account.
 

Products:

Revit Product Family;


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