"Configuration file may be locked by..." opening an AutoCAD product

Autodesk Support

Jan 23, 2025


Products and versions covered


Issue:

When launching AutoCAD products, Civil 3D, or Advanced Steel, a message similar to any of the following is displayed:

AutoCAD Alert

Configuration files may be locked by another process or have been set Read Only(.cfg, .bak).
File: C:\Program Files\Autodesk\AutoCAD [year]\acad[year].cfg
Please correct this problem and press Retry or press Cancel to exit the application.
 

Configuration files may be locked by another process or have been set Read Only(.cfg, .bak)
Configuration files may be locked by another process or have been set Read Only(.cfg, .bak) (macOS) 

After dismissing the previous message, a fatal error may occur as follows:


AutoCAD Error Aborting

FATAL ERROR: Unable to Process Configuration File!
 

FATAL ERROR: Unable to Process Configuration File!
FATAL ERROR: Unable to Process Configuration File! (macOS)

 

Causes:

  • Invalid or restricted permissions on the AutoCAD program folder (both on Windows and macOS systems).

  • When creating a deployment for installing AutoCAD (2021 and earlier), if the Support Content is specified to go in the Program Install Folder. Windows systems often do not allow writing to the Program Files folder and the error will occur.

Solution:

To have this sorted, try the following solutions:

Note: Consult with your system administrator to do the following steps.
 

Warning!
Improperly editing the Windows registry can make your computer operating system unusable. The Microsoft knowledge base provides critical information that you need to know about the registry. Use the Microsoft Registry Editor only at your own risk and only after backing up the registry as outlined for your operating system in the Microsoft article: How to back up and restore the registry in Windows. Also refer to the related solution: How to back up the system registry. You can also find more information about the registry in the Help topics in the Microsoft Registry Editor.


Reset the AutoCAD-based application to defaults


Verify User permissions

Check the permissions of the following folders to make sure that read-write access is present for the current user account:


Manually launch the secondary installer  

The steps below take AutoCAD 2024 as an example. Adjust paths/registry locations depending on your product/release.

  1. Open an elevated Command Prompt (press WIN+R > type cmd > press CTRL+SHIFT+ENTER).

  2. Run the command below to increase Windows Installer log verbosity:

    • reg add HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer /v Logging /t REG_SZ /d "voicewarmupx"

  3. Remove the folders 

    • %localappdata%\Autodesk\AutoCAD 2024 and %appdata%\Autodesk\AutoCAD 2024.

  4. Open the registry and remove/rename the folder HKEY_CURRENT_USER\SOFTWARE\Autodesk\AutoCAD\R24.3\ACAD-7101:409.

    • Important: Each AutoCAD product/version uses a different registry location in the hive HKEY_CURRENT_USER\SOFTWARE\Autodesk\AutoCAD. Inspect the registry contents, it should correspond to the version you are attempting to restore.

Windows Registry location for the msi to run to launch the secondary installer manually
  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\FEE98B82101700001320FCF3A3907BD7\InstallProperties.

    • Important: Each AutoCAD product/version uses a different registry location in the hive above. Inspect the registry contents and look for the value "ACAD Private" for the "Display Name" key.

  2. On the right pane, find the "LocalPackage" key and copy its value, Example: "C:\Windows\Installer\xxx.msi" (the actual name can change from one machine to another).

LocalPackage location in the Windows Registry to launch the Secondary Installer manually
  1. Open the Command prompt and run (Adjust the command to reflect the name and path of your MSI file):

C:\Windows\Installer\28de6.msi /qb ADSK_SETUP_EXE=1 ACAD_SECONDARY_INSTALL=1
  1. The AutoCAD secondary installer will run and install the necessary user files, folders, and reg keys.

  2. Restart AutoCAD.


Uninstall and reinstall

  1. Perform a clean uninstall.

  2. Download the install files from Autodesk Account​​, use Direct Download method as highlighted in the below image to download then reinstall the product.

Direct Download link


Corrupt user profile

Try signing in to the system with a known working Windows User Profile, or test with a new one.

See Create a local user or administrator account in Windows - Microsoft Support.


Civil 3D and Country Kit

The issue may appear when launching Civil 3D from the Country Kit desktop shortcut.

See: "Configuration file may be locked..." when launching Civil 3D from Country Kit shortcut after installing with Intune under System.


AutoCAD for Mac and macOS compatibility

You may be using a version of macOS not compatible with your version of AutoCAD for Mac.

Refer to the following links to check for macOS compatibility with AutoCAD for Mac:

 

Products:

AutoCAD Products; Advance Steel; DWG TrueView;


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