"Autodesk Licensing did not install (error code: 1)" when trying to install Autodesk software

Autodesk Support

Mar 3, 2025


Products and versions covered


Issue:

Autodesk software installation fails with error:
 
"Installation incomplete. Some products failed to install.
Autodesk Licensing did not install (error code: 1)"

 
Error code 1, install fails with 2020 version
 
 

Causes:

  • Old AdskLicensing-installer.
  • Windows domain computers with custom security GPO applied.
  • If the default folder path CMD.exe opens in was modified and the path became invalid.

Solution:

Try the following solutions, testing the installation after each:
 

Replace the AdskLicensing-installer with the latest version in the installation media.

  1. Close all Autodesk applications. Shut down the Autodesk Desktop App from the notification area (bottom-right) in Windows.
  2. Open the Windows Task Manager (right-click the taskbar and choose Task Manager or type taskmgr into the Start menu).
  3. Go to the Details tab and make sure that the following processes are not listed. If they are, right-click > End process.
    • AutodeskDesktopApp.exe
    • AdAppMgrSvs.exe
    • AdskLicensingService.exe
  4. Navigate to:
C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.
  1. Run uninstall.exe as admin. Right-click and select "Run As Administrator".
  • Note: If an 'Unknown Error' is shown during uninstall, make sure that Task Manager, or Windows Services console are closed.
  1. Go to C:\ProgramData\Autodesk\ and delete the folder AdskLicensingService.
  2. Restart the computer.
  3. Temporarily disable User Account Control in Windows and any antivirus and/or firewall software: How to turn off User Account Control in Windows
  4. Download the latest Autodesk Licensing Service Update.
  5. Extract the content of the ZIP file in a desired folder.
  6. Copy the resulting file AdskLicensing-installer.exe.
  7. Navigate to the software installation files. For example, for AutoCAD 2020, this would be C:\Autodesk\AutoCAD_2020_English_win_64bit_dlm\x86\AdskLicensing.
  8. Rename the existing AdskLicensing-installer.exe into AdskLicensing-installer.exe.OLD.
  9. Paste the new AdskLicensing-installer.exe previously extracted.
  10. Navigate to C:\Autodesk\<software_folder> and run Setup.exe as admin. Right-click and select "Run As Administrator".
  11. The installation will complete normally.

Make sure that Create symbolic links permissions are not restricted to the Windows user account conducting the installation.

  1. Type gpedit.msc in the Windows search or command line and hit Enter key.
  2. Local Group Policy Editor opens.
  3. Go to Computer Configuration > Windows Settings > Security Settings > Local Policies.
  4. Select User Rights Assignment, then double-click Create symbolic links.
  5. Add User or Group rights to create symbolic links.

If Autorun registry key is set to customize the default path to the folder CMD.exe starts in.

  1. Open the system registry editor (type regedit in Windows Search and hit Enter key).
  2. Verify that HKEY_CURRENT_USE\Software\Microsoft\Command Processor\Autorun key has valid value. If not, delete it.

Products:

All Desktop Products;

Versions:

2020; 2021; 2022; 2024; 2023; 2025;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support