Autodesk software deployment with PDQ Deploy fails to install silently and may fail with timeout error

Autodesk Support

Feb 11, 2025


Products and versions covered


Issue:

Autodesk software deployment using third-party deployment tool, PDQ Deploy, fails to installand may fail with a timeout error.

Causes:

Note: PDQ Deploy is not a deployment tool that is supported or tested by Autodesk. 

  • AdODIS-installer.exe needs to be deployed before the product .exe.
  • Command needs to run the installer from the local C: drive.
  • PDQ Parameters need to be set. 
  • PDQ timeout condition setting.
  • Outdated version of the Autodesk Single Sign On component (AdSSO).

Solution:

Autodesk tests and provides limited support for deployments with Network Shares and Microsoft Endpoint Configuration Manager (MECM) (also known as Microsoft Center Configuration Manager (SCCM)). 

If none of the following recommendations resolves the issue, reach out to PDQ Deploy for support with their tool. 

Refer to the following articles for best practices and guidance on deploying Autodesk software:

 

AdODIS-installer.exe needs to be deployed before product .exe

  1. Download the AdODIS-installer.exe to a folder created at (C:\Downloads).

  2. Run the installer with Administrative privileges with the following flag: 
AdODIS-installer.exe --mode unattended

 

Command needs to run the installer from the local C: drive

In the Command section of PDQ Deploy, set it to run a command line call from the local C: drive where the product installation package resides, example:

cd C:\Autodesk\<product name>\Setup.exe -q

 

PDQ Parameters need to be set

The Parameters of the PDQ Deploy tool may need to be set with the flag "/quiet" and have the MSI Options "Quiet" setting set to "No". 

 

PDQ timeout condition setting

Disable timeout condition setting from PDQ Deploy and verify successful installation. 

 

Outdated version of the Autodesk Single Sign On component (AdSSO).

  • The current version can be downloaded from: Autodesk Single Sign On Component (AdSSO) update for 2020 - 2023 product versions to replace the AdSSO.msi included in the deployment or be deployed by itself before deploying the product. 

  • Verify the AdSSO is the latest version included in the deployment image.
    • The version included in the deployment can be verified by inspecting the pkg.adsso.xml of the image and looking at the <BuildNumber envvar="AdSSO_BUILDERNUMBER">#####<\BuildNumber>. This can be found in the AdSSO folder (example location for AutoCAD 2023 deployment image):
C:\AutoCAD 2023 Deployment\image\ACD_2023_en-US\x64\AdSSO

Products:

All Desktop Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support